Closed Bug 791191 Opened 10 years ago Closed 10 years ago

Nested svg:use does not update to reflect changes in referenced elements

Categories

(Firefox :: Untriaged, defect)

15 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 467498

People

(Reporter: blambov, Unassigned)

Details

Attachments

(1 file)

Attached image use-scale-simple.svg
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_1) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1

Steps to reproduce:

In the attached file a script changes the scale value of an element. This element is used directly, via a mask, and via a nested use element.


Actual results:

The nested use does not update to reflect the change in scale.


Expected results:

All instances of the unit element should have changed scale.
The expected behaviour can be seen in Chrome or Opera.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 467498
Depends on: 908075
No longer depends on: 908075
Depends on: 929396
You need to log in before you can comment on or make changes to this bug.