Status

Core Graveyard
File Handling
--
critical
VERIFIED DUPLICATE of bug 79018
17 years ago
2 years ago

People

(Reporter: Stephen Anderson, Assigned: dougt)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9+) Gecko/20010506
BuildID:    2001050608

Choosing save to disk in the new file download dialog leads to Mozilla crashing
upon completion of download.

Reproducible: Always
Steps to Reproduce:
1. Goto http://ftp.mozilla.org/pub/mozilla/nightly/latest/
2. Click on win32 installer build link
3. Choose save to disk
4. Give location and start to download.

Actual Results:  After completing download (leave download dialog window open
checkbox NOT checked) mozilla crashes.

Expected Results:  Window should go away and mozilla should not crash.

Talkbacks: TB30075272H TB30075380K

Comment 1

17 years ago
This is occurring on Linux x86 with the current (20010507050215) CVS too.  I get
the message:

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE)
[nsIRequest.QueryInterface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location:
"JS frame :: chrome://global/content/helperAppDldProgress.js :: anonymous ::
line 81"  data: no]
************************************************************

on the console right before the crash.

Updated

17 years ago
Keywords: qawanted

Comment 2

17 years ago
-> ftp, this is in download resume/pause code i think, so belongs to dougt. 
Seeing this too on linux cvs from today, 0.9.1 candidate
Assignee: neeti → dougt
Component: Networking: HTTP → Networking: FTP
Keywords: qawanted → crash, mozilla0.9.1
OS: Windows 2000 → All
(Assignee)

Comment 3

17 years ago
dup

*** This bug has been marked as a duplicate of 79018 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
doug: i still see the assertion though today (cvs pull), not the crash anymore.
(Assignee)

Comment 5

17 years ago
maybe I need a try/catch block around that QI.  

Updated

17 years ago
QA Contact: tever → benc

Updated

16 years ago
Component: Networking: FTP → File Handling
QA Contact: benc → sairuh
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.