Firefox 15 and 16 CRASH working with javascript alerts and popups

RESOLVED DUPLICATE of bug 701299

Status

()

Core
General
--
critical
RESOLVED DUPLICATE of bug 701299
6 years ago
6 years ago

People

(Reporter: Mauricio Haro Acosta, Unassigned)

Tracking

({crash})

15 Branch
x86_64
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 661259 [details]
jacascrip code that recreate the bug

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713224749

Steps to reproduce:

Hi friends,

In some parts of my aplication I still work with popups. When I submit the popup, the aplication needs to execute a javascript function from the opener window; in this function I call an alert or a confirm window. If the popup is closed before I accept the alert, Firefox crash.

I'm attaching a zip with a couple files to recreate this bug and the crash screenshot, but the code I use is something like this:

*** POPUP CODE ***
When I submit the form I execute a javascript function:

function closePopup() {
    /* SOME CODE HERE */
    opener.parentFunction();
    window.close();
}

*** OPENER CODE ***
function parentFunction() {
    /*SOME CODE HERE*/
    alert ('Hello');
    return;
}



Actual results:

Firefox Crash


Expected results:

Close the popup, show the alert window and firefox not crash
confirming with Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0.1

Again an crash that soccoro doesn't seem to like :-(
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Keywords: crash
OS: Linux → All
Product: Firefox → Core
Looks as if the reporter got a crash dialog - can we get the report ID from about:crashes?
The linux and the windows crash IDs are useless. Example bp-a0b0a7d8-4ed0-46af-a61e-67dd221209141 and I can't get a usefull stack from Windbg :-(

Comment 4

6 years ago
(In reply to Matthias Versen (Matti) from comment #3)
> Example bp-a0b0a7d8-4ed0-46af-a61e-67dd221209141
It's bp-a0b0a7d8-4ed0-46af-a61e-67dd22120914 and bug 701299 that is fixed in 16.0b3.
Status: NEW → RESOLVED
Crash Signature: [@ nsGlobalWindow::LeaveModalState(nsIDOMWindow*) ]
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 701299
Scoobidiver: We had a socorro outage and that's the reason why the crash IDs didn't work. I mid-aired with you while resolving this report....

Comment 7

6 years ago
I can reproduce the crash  bp-72e056fa-aa63-4942-9837-5511f2120914 in Firefox15.0.1 windows7 build.
However, I cannot reproduce in Firefox16beta, Aurora17.02 and Nightly18.01 windows7 build.

FYI.
In Linux build, No popup pops up in Firefox16beta and later.
I filed a Bug 791328 .
You need to log in before you can comment on or make changes to this bug.