I can't install Firefox (Beta or stable) from google play to my samsung galaxy ace

RESOLVED FIXED

Status

()

RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: sahnovski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 661279 [details]
SC20120914-204750.png Screenshot from device

User Agent: Mozilla/5.0 (Windows NT 6.2) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1

Steps to reproduce:

I cant' see Firefox in Google Play from my Samsung Galaxy Ace. When i go to Google Play from browser I see like: You device does not suppurt this application
But I see my device here: http://www.mozilla.org/en-US/firefox/mobile/platforms/
That bug is true for stable firefox version and for beta.
My model device is GT-5830 frimeware: S5830XXKPT Android 2.3.6


Actual results:

Not show me Forefox for installation


Expected results:

Show firefox for intallation and work clear :)
(Reporter)

Updated

6 years ago
OS: Windows 8 → Android
Hardware: x86 → ARM
(Reporter)

Comment 1

6 years ago
Attached screenshot was created when I try go in mobile browser to Firefox official site and tap to "Download Firefox for Android" than open Google Play
Hi,

Thanks for letting us know and filing this bug. You're right, the device is misleading and it is a mistake to put it up there. Currently Firefox Beta supports devices with 800MHz and 512MB available RAM. The GT-5830, while it meets the CPU recommendation, the available ram available on the device is lower than the recommended.

The good news is that you can still get Firefox Beta available on our FTP should you choose, but be warned that updates will not be offered unless you manually install a new APK.

Sorry for the confusion!

http://ftp.mozilla.org/pub/mozilla.org/mobile/releases/

I've remedied this with a pull-request: https://github.com/mozilla/bedrock/pull/358
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

6 years ago
Thank you!

Comment 4

6 years ago
So, is this the reason why firefox beta crash at starting on my Samsung Ace? Not enough memory?
You need to log in before you can comment on or make changes to this bug.