Catlee was telling me today that folks weren't quite sure what the 'schema_version' of the blob was for. What it is is a way to tell the difference between newer and older versions of the JSON blob that we store in the database. For example, if we rip out 'fakePartials' from the JSON at some point we'll want to increment the schema version so that things that parse it can expect not to have it in the newer version. Maybe blobVersion is a better name?
Not going to be worked on soon.
mass component change
We might want to do this as part of bug 1021021, where we're adding a completely different schema (ie, doesn't precede or follow any of the current ones). We should probably use something that suggests there's not a linear line of blob types.