window.open() makes document not update.

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
--
major
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Xuân Baldauf, Assigned: Dan M)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9+) Gecko/20010503
BuildID:    2001050304

If JavaScript code

  window.open("","mywindow");

is executed, nothing happens and no javascript code can be further executed.

Reproducible: Always
Steps to Reproduce:
1. Go to http://justchat4.medium.net:4000/chat/test/mozilla/formSubmit/index.html
2. Click on "open and close a new window"


Actual Results:  A new window should pop up.

Expected Results:  No window pops up. No JavaScript code will be executed after
clicking on that link. If you close mozilla, it still will hang (you can see
this in the windows taskbar).

The test case originally was planned as a test case for bug 68321. Maybe both
bugs are somehow related, maybe not.

I set "severity" to "major" because this is a basic javascript function, even if
I do not need it for my projects, currently.

Comment 1

17 years ago
Browser, not engine --> DOM Level 0
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale

Updated

17 years ago
Keywords: hang

Comment 2

17 years ago
Marking WORKSFORME. Using build 2001050620 on WinNT, the 
"open and close a new window" link seems to work just fine. 

Also, keying this directly in the URL bar is working fine: 

            javascript: window.open("","mywindow");


Xuan, could you try this again with a more recent build?
If it works fine for you, please mark this bug "Verified".
Otherwise, you can reopen it - thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 3

17 years ago
works for me too with 2001050620 on win2k sp1

Comment 4

17 years ago
I have seeing this kind of failure a lot in various sites. I got an Alert dialog
"window.open("","mywindow"); 1"
when I clicked the indicated URL using 2001050705 trunk for Mac.
Afterwards, a phantom window is listed under task menu. This usually causes hang
on exit (bug 73893).
I do not think it is a good idea to change status based on the result of testing
in a different platform from original report.
Reopening and All/All.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 5

17 years ago
Does _not_ work for me for Mozilla 2001050620, Win98SE.

Can anyone please try to positively or negatively confirm it on Win98SE?

Comment 6

17 years ago
There was a new window crasher late last week.   Can't remember the bug for
it...you are probably using one of those builds.  You should really not report a
bug on the 7th using a build from the 3rd.

Works for me on win2k using build 2001050704

Jake

Comment 7

17 years ago
Could you please changing status to WFM based on the result of W2k platform?
This has been confirmed in W98 and MacOS9.1.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

17 years ago
This bug happens even in the latest builds on Linux from the release 0.9

Comment 9

17 years ago
worksforme in case to report with 2001052020 on Win95

But after the third alert form, I get the What to do with download form for
downloading http://justchat4.medium.net:4000/chat/test/mozilla/formSubmit/

Why?
worksforme.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 11

17 years ago
This is still failing. 2001052308 trunk for Mac.
Status: RESOLVED → REOPENED
OS: Windows 98 → All
Hardware: PC → All
Resolution: WORKSFORME → ---

Comment 12

17 years ago
Still hangs with nightly mozilla 2001060708 on linux. On the top of that all
links stop responding. Navigation ia possible only with back and forward buttons
and typing an URL to the address bar.

btw, could not verify with the above testcase link, but here's how I stumbled
across this:
1) Goto www.autosport.com.
2) select Formula 1 -> Gallery from the javascript menu on the left.
3) Follow a link to any Grand Prix that has images (as of Jun 12 Monaco is the
latest).
4) Click on any gallery image to open it.

What sould happen:
5) A window should open containing the large image.

What happens:
5) Mozilla stops responding to clicks on links.

So this is not really a hang then? Removing hang keyword and changing summary.
Keywords: hang
Summary: window.open() makes mozilla hang → window.open() makes document not update.

Comment 14

17 years ago
This also causes form submission impossible and causes hang on exit (see also
bug 73893).
nominating for 0.9.2.
This has regressed several times recently. I suppose there be a fundamental fix
for this to make it unaffected by other changes.
Keywords: mozilla0.9.2
I still can't reproduce this, over to danm in hope that he can reproduce this...
Assignee: jst → danm
Status: REOPENED → NEW

Comment 16

17 years ago
I've tried the wy from Johannes Almiala ... but all do work with Build
2001062904 under Win95.

Comment 17

17 years ago
It is now WFM in 2001062914 trunk.
I hope this will not regress any more.
(Assignee)

Comment 18

17 years ago
javascript:window.open("","mywindow") in the URL bar WFM in today's trunk build, 
Redhat/Sawfish, Win2k, Mac OS 9. Closing. If you (whoever you are) reopen after 
finding a website that shows the problem even though window.open in the URL bar 
doesn't, JS specifics would be nice.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 19

17 years ago
Well it doesn't work in certain situations.
For example,

1] http://www.autosport.com/gallery_section.cfm?r=6489&series=5
2] click on any thumbnail images in center. 

EXPECTED RESULTS:
New popup window should open to enlarge clicked image.

ACTUAL RESULTS:
Nothing happens.

BUILDS USED:2001-08-28-09-trunk on Win-95.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 20

17 years ago
see bug with 2001083016 under Linux.

correct my last comment, I've also that problem.

The problem inherits after a unkown time or a unknown doing with mozilla.
Sometimes it works and sometimes not. If it don't work and I close _all_ mozilla
windows then it left running processes. If I kill them and start mozilla new the
problem disappears.

Comment 21

17 years ago
Created attachment 50230 [details]
please read the comment before test

Comment 22

17 years ago
There is a new testcase which show me the bug under Linux with build 20010920!

The testcase loads the car images from the example from Prashant Desale (2
comments above) this are round 350kByte.

The images have a link to a javascript function with window.open()

After you have fully load the page (with images) and click on one image mozilla
doesn't show a new window with the same page. It hangs a little bit around. The
stop button and the mozilla activity animation disappear on my 256MB maschine
under KDE.

If it works fine by you, close the opened window, reload the testcase and try
again (the bug should seen after 1, 2 or 3 loads).

If I reduse the count of images, sometimes it works fine then I also reload the
testcase and the bug is showing again.

It looks like it is a Memory problem.

Ok, go on.
After you see the bug you can go to every page and all works correctly. All
scripts should work, but not window.open("","");
Example http://community.zet.net ... the page works but if you click on the left
side on "User online" no popup comes.

(To try, click on "This works fine", behind the link is a function which open an
alert window.)

Ok, I hope it helps you.

Take also a look to bug #88355 it looks related ... but seems a little bit
other, because the stop button and the animation don't go away.

Comment 23

16 years ago
is dup of closed bug 104769

I've tried my testcases and I'm happy to see, that all works well.

Comment 24

16 years ago
let's wait for Xuan's comment before marking dup
(Reporter)

Comment 25

16 years ago
Works for me with build 2001102503.

Updated testcase URL.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.