Closed Bug 791527 Opened 7 years ago Closed 7 years ago

crash in mozilla::net::ProxyAutoConfig::SetupJS @ JS_ExecuteScript

Categories

(Core :: Networking, defect, critical)

18 Branch
All
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla18
Tracking Status
firefox18 + fixed

People

(Reporter: scoobidiver, Assigned: mcmanus)

References

Details

(Keywords: crash, regression, topcrash, Whiteboard: [startupcrash][qa?])

Crash Data

Attachments

(1 file)

With that stack, it first appeared in 18.0a1/20120915. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e5af3d785252&tochange=9fff2012b66c
It's likely a regression from bug 769764.

Signature 	JS_ExecuteScript More Reports Search
UUID	23d49af0-e66d-4be7-8566-a53992120916
Date Processed	2012-09-16 00:30:16
Uptime	6
Last Crash	21 seconds before submission
Install Age	6.2 minutes since version was first installed.
Install Time	2012-09-16 00:23:40
Product	Firefox
Version	18.0a1
Build ID	20120915030531
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 37 stepping 5
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	
AdapterVendorID: 0x10de, AdapterDeviceID: 0x0a75, AdapterSubsysID: 03701025, AdapterDriverVersion: 8.17.11.9716
D3D10 Layers? D3D10 Layers- 
EMCheckCompatibility	True
Adapter Vendor ID	0x10de
Adapter Device ID	0x0a75
Total Virtual Memory	4294836224
Available Virtual Memory	4011556864
System Memory Use Percentage	62
Available Page File	2299662336
Available Physical Memory	772534272

Frame 	Module 	Signature 	Source
0 	mozjs.dll 	JS_ExecuteScript 	js/src/jsapi.cpp:5680
1 	xul.dll 	mozilla::net::ProxyAutoConfig::SetupJS 	netwerk/base/src/ProxyAutoConfig.cpp:590
2 	xul.dll 	nsACString_internal::Append 	obj-firefox/dist/include/nsTSubstring.h:400
3 	xul.dll 	mozilla::net::ProxyAutoConfig::Init 	netwerk/base/src/ProxyAutoConfig.cpp:562
4 	xul.dll 	ExecutePACThreadAction::Run 	netwerk/base/src/nsPACMan.cpp:178
5 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:624
6 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:257
7 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:395
8 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:90
9 	msvcr100.dll 	_callthreadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:314
10 	msvcr100.dll 	_threadstartex 	f:\dd\vctools\crt_bld\self_x86\crt\src\threadex.c:292
11 	kernel32.dll 	BaseThreadInitThunk 	
12 	ntdll.dll 	__RtlUserThreadStart 	
13 	ntdll.dll 	_RtlUserThreadStart

More reports at:
https://crash-stats.mozilla.com/report/list?signature=JS_ExecuteScript
missing a null check from compile.. not sure where I lost that along the way
Assignee: nobody → mcmanus
Attached patch patch 0Splinter Review
Attachment #661655 - Flags: review?(cbiesinger)
It's #6 top browser crasher over the last day.
Keywords: topcrash
Comment on attachment 661655 [details] [diff] [review]
patch 0

still seems surprising that this returns null so often?! is this for syntax errors or something>
Attachment #661655 - Flags: review?(cbiesinger) → review+
It stopped spiking after 18.0a1/20120917. The working range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3f0587ce1774&tochange=0d3b17a88d5f
(In reply to Scoobidiver from comment #5)
> It stopped spiking after 18.0a1/20120917. The working range is:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=3f0587ce1774&tochange=0d3b17a885f

it stopped spiking because 769764 backed out for an unrelated orange. When it goes back in it will go in with the r+ fix on this bug.
https://hg.mozilla.org/mozilla-central/rev/ac9b018f79a8
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
QA Contact: manuela.muntean
Whiteboard: [startupcrash] → [startupcrash][qa?]
You need to log in before you can comment on or make changes to this bug.