Note: There are a few cases of duplicates in user autocompletion which are being worked on.

"other origin" bar persists after pressing Back button to return to same-origin page

VERIFIED FIXED in Firefox 17

Status

()

Firefox for Android
Web Apps
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: myk, Assigned: wesj)

Tracking

unspecified
Firefox 18
ARM
Android
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox17 fixed, firefox18 verified)

Details

(Whiteboard: [blocking-webrtandroid1+])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 661697 [details]
screenshot

If you go from a page in a webapp's origin to a page in another origin, then press the Android Back button to return to the page in the webapp's origin, the "other origin" bar doesn't go away.

Steps to Reproduce:

1. install and open the Firefox Marketplace app;
2. tap the "Log in / Register" button to go to a page at the origin https://login.persona.org;
3. tap the Android Back button.

Expected Results: the origin bar disappears.

Actual Results: the origin bar persists (and continues to show the origin https://login.persona.org).

Updated

5 years ago
Priority: -- → P1
Whiteboard: [blocking-webrtandroid1+]
(Assignee)

Comment 1

5 years ago
Created attachment 663171 [details] [diff] [review]
Patch

In this case we're actually closing a tab and selection an old tab. No "location change" event fires. I think we probably want to update this any time the selected tab changes though.
Attachment #663171 - Flags: review?(mark.finkle)
Comment on attachment 663171 [details] [diff] [review]
Patch

Agreed
Attachment #663171 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/71b59b120de8
(Assignee)

Comment 4

5 years ago
Comment on attachment 663171 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 771915
User impact if declined: Other origin bar persists some times when it shouldn't
Testing completed (on m-c, etc.): Landed on mc today
Risk to taking this patch (and alternatives if risky): Very low risk. Webapp only fix for a situation that's fairly rare.
String or UUID changes made by this patch: None.
Attachment #663171 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
Comment on attachment 663171 [details] [diff] [review]
Patch

[Triage Comment]
Bug fix for new feature - approving for Aurora 17.
Attachment #663171 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/71b59b120de8
Assignee: nobody → wjohnston
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox18: --- → verified
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/9d03aa5abb5a

Updated

5 years ago
status-firefox17: --- → fixed
You need to log in before you can comment on or make changes to this bug.