Closed Bug 791750 Opened 9 years ago Closed 9 years ago

Permit delivering HTTP channel OnDataAvailable to a non-main thread

Categories

(Core :: Networking: HTTP, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 497003

People

(Reporter: jduell.mcbugs, Unassigned)

Details

For single-process Firefox we can save a lot of main thread event traffic (esp for downloads and other large loads) by allowing necko traffic to get delivered directly to a non-main thread if that's the eventual client.

(This won't work easily in e10s because we rely on IPDL for delivery, and it requires all send/receipts to happen on the main thread, for now at least).

I took some notes on this a long time ago:

  https://wiki.mozilla.org/Necko:_support_sending_OnDataAvailable()_to_other_threads

The idea here is to permit OnDataAvailable() to be delivered directly to a non-main thread--OnStartRequest and possibly OnStopRequest would still be delivered on the main thread.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497003
You need to log in before you can comment on or make changes to this bug.