iPad smart cover animation at http://www.apple.com/ipad/features/ is very slow because we decode too many images

RESOLVED DUPLICATE of bug 791731

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 791731
6 years ago
6 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
STR:

* http://www.apple.com/ipad/features/
* Scroll down to the smart cover section, second from the bottom.
* "Unwrap" and "wrap" the cover by dragging your mouse.

Actual results: Animation is stuttery, and flashes between showing the relevant image and showing a white frame.

Profiling with perf shows that we're spending all our time in the JPEG decoder, so this is very likely a discarding issue.  Probably fallout from bug 683290.

But what I don't get is, that bug is supposed to unlock images which aren't in the DOM, but not cause us to immediately discard them, right?  So what's going on here?

I found this bug by following a link out of https://docs.google.com/document/pub?id=1GWTMLjqQsQS45FWwqNG9ztQTdGF48hQYpjQHR_d1WsI (which is pretty interesting in and of itself).
(Reporter)

Updated

6 years ago
Blocks: 683290
(Reporter)

Updated

6 years ago
Keywords: regression
Likely related bug 791731.
(Reporter)

Comment 2

6 years ago
(In reply to Timothy Nikkel (:tn) from comment #1)
> Likely related bug 791731.

Very likely the same bug, although fwiw I don't see bug 791731 on my powerful desktop machine, but I do see this bug.  So this bug may be thrashing the decoder harder.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 791731
You need to log in before you can comment on or make changes to this bug.