Closed Bug 791854 Opened 9 years ago Closed 9 years ago

Disable noion armv7 android builds/tests

Categories

(Release Engineering :: General, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Callek, Assigned: Callek)

References

Details

Attachments

(6 files)

So, after a chat with dvander it appears we don't need the armv7-noion tests after we clarified a few facts:

* Armv6 builds are built without ionmonkey
* Armv6 tests are [currently] run on tegras, which are an armv7 chipset
* the JIT/JS code that is armv6 specific are determined at runtime, not build time.

Due to this, the specific armv6-noion builds are suitable for the coverage the B2G team needed out of noion-on-armv7.

We'll need armv7-noion builds *again* IFF we start testing armv6 builds on an armv6-chipset prior to having B2G specific testing up.

... This bug is to track that work, and will be primarily backing out the [rebased] changes from Bug 789373 - use the new --disable-ion flag for specific b2g-related builds
This attachment removes the noion configs from m-c, and will be landed after the reconfig to disable noion builds
Attachment #661951 - Flags: review?(aki)
This patch as well would land after the reconfig.
Attachment #661954 - Flags: review?(aki)
Attachment #661956 - Flags: review?(aki)
Attachment #661951 - Flags: review?(aki) → review+
Attachment #661954 - Flags: review?(aki) → review+
Attachment #661956 - Flags: review?(aki) → review+
Attachment #661957 - Flags: review?(aki)
Comment on attachment 661957 [details] [diff] [review]
[custom] remove refs to noion

We don't need the backslashes in the |if self.OS in| check, but they don't hurt.
Attachment #661957 - Flags: review?(aki) → review+
Attachment #661960 - Flags: review?(aki)
This should land ~24 hours after the reconfig, to give any longer-lasting jobs a chance to properly show.
Attachment #661961 - Flags: review?(philringnalda)
Comment on attachment 661960 [details] [diff] [review]
[config] Remove noion from production

passes test-masters.sh (with specified -j), and passes the grep -rl test.
Attachment #661960 - Flags: review?(aki) → review+
Comment on attachment 661960 [details] [diff] [review]
[config] Remove noion from production

http://hg.mozilla.org/build/buildbot-configs/rev/6e0589868327
Attachment #661960 - Flags: checked-in+
(In reply to Aki Sasaki [:aki] from comment #5)
> Comment on attachment 661957 [details] [diff] [review]
> [custom] remove refs to noion
> 
> We don't need the backslashes in the |if self.OS in| check, but they don't
> hurt.

Since I was effectively backing out your change in this hunk, I opted not to re-remove the \'s (for now)
Comment on attachment 661961 [details] [diff] [review]
[tbpl] remove refs

Actually, it should land 31 days after the reconfig, after all the noion logs are gone from ftp.m.o and nobody can be looking at anything on tbpl and getting confused by the way that every Android row has two builds and two sets of most tests, but whatever - between the lag until the next push to production tbpl and the way that almost nobody looks at them while they are fresh, much less once they are stale, it won't make any practical difference.
Attachment #661961 - Flags: review?(philringnalda) → review+
Duplicate of this bug: 790933
Blocks: 793994
Resolving as "Fixed" without landing teh remaining patches, since we need to re-enable these builds in Bug 793994
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.