Mac nightly causing mem leak + syslogd load

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Anshu Prateek, Unassigned)

Tracking

18 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20120917030530

Steps to reproduce:

Browsing various sites on nightly 2012-09-17 build.


Actual results:

System memory becoming full.  Activity monitor showed syslogd taking over 1GB of memory. On checking /var/log/system.log , saw the following in the logs:

Sep 18 10:29:45 listsettle-lm [0x0-0x4e04e].org.mozilla.nightly[0]: objc[885]: Object 0x18c7a6380 of class __NSCFData autoreleased with no pool in place - just leaking - break on objc_autoreleaseNoPool() to debug
Sep 18 10:29:45 listsettle-lm [0x0-0x4e04e].org.mozilla.nightly[0]: objc[885]: Object 0x18c7a6400 of class __NSCFData autoreleased with no pool in place - just leaking - break on objc_autoreleaseNoPool() to debug

There were so many instances of this error that syslogd was not able to cope up and was running 5 minutes behind!

I ven't checked it yet with a clean nightly sans plugins. 

The above is easily reproduced on my host. It happens after 10-15 mins of browsing.



Expected results:

Memory leak should not happen.
(Reporter)

Updated

6 years ago
OS: Linux → Mac OS X
Hardware: x86 → x86_64
Probably already fixed by the backout https://bugzilla.mozilla.org/show_bug.cgi?id=507578#c20.

Can you please test tomorrows nightly and report back ?
(Reporter)

Comment 2

6 years ago
yes, its been working fine since the day after nightly.

regards
Anshu Prateek
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 3

5 years ago
I've hit this bug with v. 18. For me it's tickled when I use a local proxy.pac file. To tickle:

System Preferences>Network>Advanced...>Proxies>Automatic Proxy Configuration: file://localhost/Library/Internet Plug-Ins/proxy.pac

Firefox>Preferences>Advanced>Network>Settings...>Use system proxy settings

As this bug already has a RESOLVED status, I'll start a new ticket.
You need to log in before you can comment on or make changes to this bug.