Closed Bug 792060 Opened 7 years ago Closed 7 years ago

about:memory?verbose is unusable on a Galaxy Nexus

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 18

People

(Reporter: kats, Assigned: capella)

References

Details

(Keywords: regression)

Attachments

(2 files, 3 obsolete files)

See attached screenshot. When I load about:memory?verbose on my Galaxy Nexus I get the right content but it's so small that it's unreadable. I also cannot zoom in to make the text more readable, presumably because the page has user-scalable=false set in the meta-viewport tag.
Assignee: nobody → markcapella
Status: NEW → ASSIGNED
Attached patch Patch (v1) (obsolete) — Splinter Review
Yah, this displays odd on my Galaxy S3 also ... somehow missed the regression when changing approach in the original patch.

I like allowing user-scalable, but it still left the page displayed weird while rotating the screen especially. Changing the CSS (see attached) to match the verbose and non-verbose styles works nicely on my device.
Attachment #662509 - Flags: feedback?(bugmail.mozilla)
Attached image Screen 1 (obsolete) —
Attached image Screen 2 (obsolete) —
Comment on attachment 662509 [details] [diff] [review]
Patch (v1)

Works for me
Attachment #662509 - Flags: feedback?(bugmail.mozilla) → feedback+
Comment on attachment 662509 [details] [diff] [review]
Patch (v1)

njn ... thoughts / issues here?
Attachment #662509 - Flags: feedback?(n.nethercote)
Comment on attachment 662509 [details] [diff] [review]
Patch (v1)

Seems fine, thanks.
Attachment #662509 - Flags: feedback?(n.nethercote) → feedback+
Comment on attachment 662509 [details] [diff] [review]
Patch (v1)

Margaret... see any problems here?
Attachment #662509 - Flags: review?(margaret.leibovic)
Comment on attachment 662509 [details] [diff] [review]
Patch (v1)

Review of attachment 662509 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/themes/core/aboutMemory.css
@@ +5,5 @@
>  /* This file is used for both about:memory and about:compartments. */
>  
> +body.verbose pre.entries {
> +  overflow-x: hidden;
> +  text-overflow: ellipsis;

I feel like it would be more useful to just have the text overflow like it does on desktop, since just being able to pan inside the body gives you less visible text. I feel like the ideal thing to do for readability here would be to make the white background expand with the text, but that's also an issue on desktop.
Attached patch Patch (v2)Splinter Review
Well, the fix simpler then, (Attached).

I thought not letting the text overflow might be a better presentation for mobile, but being consistent with desktop is a valid concern.
Attachment #662509 - Attachment is obsolete: true
Attachment #662510 - Attachment is obsolete: true
Attachment #662511 - Attachment is obsolete: true
Attachment #662509 - Flags: review?(margaret.leibovic)
Attachment #663421 - Flags: review?(margaret.leibovic)
Comment on attachment 663421 [details] [diff] [review]
Patch (v2)

Thanks. I find panning to be better with this fix, also.
Attachment #663421 - Flags: review?(margaret.leibovic) → review+
https://hg.mozilla.org/mozilla-central/rev/091af1edcd98
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Build ID: 18.0 (2012-10-08) Nightly Channel
          19.0 (2012-10-09) Nightly Channel
Device: Samsung Galaxy Nexus
OS: Android 4.1

The page is loaded zoomed in. The text is readable and can be panned and zoomed in/out.

Marking bug as Verify Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.