Closed Bug 792157 Opened 8 years ago Closed 8 years ago

Update callers in SeaMonkey code to reflect changes in nsIFaviconService

Categories

(SeaMonkey :: General, defect, major)

defect
Not set
major

Tracking

(seamonkey2.15 fixed)

RESOLVED FIXED
seamonkey2.15
Tracking Status
seamonkey2.15 --- fixed

People

(Reporter: mcsmurf, Assigned: mcsmurf)

References

Details

Attachments

(1 file)

Bug 741059 changed the nsIFaviconService and the mozIAsyncFavicons interface. We need to update our code to reflect those changes.
Right. This is what you get (compiled a build myself):

Error: NS_ERROR_XPC_NOT_ENOUGH_ARGS: Not enough arguments [mozIAsyncFavicons.setAndFetchFaviconForPage]
Source File: chrome://navigator/content/tabbrowser.xml
Line: 705

m-c changeset: http://hg.mozilla.org/mozilla-central/rev/89027f6e7662
"Bug 741059 - Part 4: Update the callers to mozIAsyncFavicon::SetAndFetchFaviconForPage"
Non-shared files:
* browser/base/content/tabbrowser.xml
* browser/components/feeds/src/FeedWriter.js
Severity: normal → major
Depends on: 741059
Duplicate of this bug: 792168
Attached patch PatchSplinter Review
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #662273 - Flags: review?(neil)
Comment on attachment 662273 [details] [diff] [review]
Patch

Sorry for forgetting SM! :(
Attachment #662273 - Flags: review?(neil) → review+
Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/f97bbaa649d5
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.15
You need to log in before you can comment on or make changes to this bug.