Closed Bug 792171 Opened 7 years ago Closed 7 years ago

B2G: Investigate if we need separate HTTP cache per {appId, inBrowser, isPrivate}

Categories

(Core :: Networking: Cache, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 818667
blocking-kilimanjaro ?

People

(Reporter: jduell.mcbugs, Unassigned)

References

Details

We've got cookie-jars, appcache-jars, IndexedDB-jars, etc.  We need to figure out if we need per-{appId, inBrowser} HTTP cache namespaces, too.

The main argument for this is that content is likely to vary with different cookies, and it's unlikely that we can rely on servers to send Vary: Cookie in that case.  AFAIK the cache doesn't do anything to try to handle content varying with cookies (right?).   If that's true it's a strong argument for separate namespaces.

We've been assuming we don't need this for B2G v1, as collisions don't seem very likely until we support multiple browser apps.
We'd want to isolate nextGen-Private browsing per app too...
Summary: B2G: Investigate if we need separate HTTP cache per {appId, inBrowser} → B2G: Investigate if we need separate HTTP cache per {appId, inBrowser, isPrivate}
Correct, cache only does something special per-cookie if a Vary: Cookie header is present.
blocking-kilimanjaro: --- → ?
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 818667
You need to log in before you can comment on or make changes to this bug.