Last Comment Bug 792181 - Suppress all WN pages for updates to FF16 (and only 16)
: Suppress all WN pages for updates to FF16 (and only 16)
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Robert Strong [:rstrong] (use needinfo to contact me)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 12:47 PDT by Alex Keybl [:akeybl]
Modified: 2014-01-10 10:41 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
verified
unaffected
unaffected
unaffected


Attachments
Patch rev1 - tested - beta branch only (1.97 KB, patch)
2012-09-24 15:02 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
ehsan: review+
Details | Diff | Review
patch rev2 (3.05 KB, patch)
2012-09-24 15:44 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
gavin.sharp: review+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review
Don't run test (438 bytes, patch)
2012-09-24 19:40 PDT, Robert Strong [:rstrong] (use needinfo to contact me)
robert.strong.bugs: review+
Details | Diff | Review

Description Alex Keybl [:akeybl] 2012-09-18 12:47:55 PDT
We need to suppress all WN pages for updates to FF16 (and only 16) due to bug 789422, which will be first "fixed" in the update from FF16->FF17 (although the code is already in FF16).
Comment 1 Robert Strong [:rstrong] (use needinfo to contact me) 2012-09-18 12:48:54 PDT
Questions from email for this bug

I am fairly certain that it would suppress all WN pages for that version. Is that ok?

Regarding assigning it to me, when do you need this by?
Comment 2 Robert Strong [:rstrong] (use needinfo to contact me) 2012-09-18 12:50:09 PDT
Answers

(In reply to Robert Strong [:rstrong] (do not email) from comment #1)
> Questions from email for this bug
> 
> I am fairly certain that it would suppress all WN pages for that version. Is
> that ok?
Yep - that'd be great. As long as 16->17 isn't suppressed (we may want a WN page there).

> 
> Regarding assigning it to me, when do you need this by?
Next Tuesday would be the beta 5 go to build, so it'd be great to get it into the build prior.
Comment 3 Robert Strong [:rstrong] (use needinfo to contact me) 2012-09-18 12:51:12 PDT
Also, since this will only be needed on the Firefox 16 train it only needs to land there.
Comment 4 Robert Strong [:rstrong] (use needinfo to contact me) 2012-09-24 15:02:08 PDT
Created attachment 664237 [details] [diff] [review]
Patch rev1 - tested - beta branch only
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-09-24 15:19:38 PDT
Is getPostUpdateOverridePage garanteed to be called in all cases? Wouldn't it be safer to also remove the values of the startup.homepage* prefs?

http://mxr.mozilla.org/mozilla-beta/source/browser/branding/official/pref/firefox-branding.js#5
Comment 6 Robert Strong [:rstrong] (use needinfo to contact me) 2012-09-24 15:23:53 PDT
to be honest, if I were to go with a "safer" method I would prefer to do it with code removal and not with pref removal.

I'll stop my other work on the stub installer and dive further into this to make doubly sure.
Comment 7 Robert Strong [:rstrong] (use needinfo to contact me) 2012-09-24 15:44:15 PDT
Created attachment 664253 [details] [diff] [review]
patch rev2
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-09-24 15:46:47 PDT
Comment on attachment 664253 [details] [diff] [review]
patch rev2

yeah, this is exactly what I had in mind
Comment 9 Robert Strong [:rstrong] (use needinfo to contact me) 2012-09-24 15:48:50 PDT
Comment on attachment 664253 [details] [diff] [review]
patch rev2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 307181
User impact if declined: user's will see the what's new page after an update
Testing completed (on m-c, etc.): manual testing.
Risk to taking this patch (and alternatives if risky): minimal risk.
String or UUID changes made by this patch: none
Comment 10 Alex Keybl [:akeybl] 2012-09-24 17:03:34 PDT
Comment on attachment 664253 [details] [diff] [review]
patch rev2

[Triage Comment]
Thanks for the one off patch and r+ guys. FF16 will be silent!
Comment 11 Robert Strong [:rstrong] (use needinfo to contact me) 2012-09-24 17:10:24 PDT
Pushed to mozilla-beta
https://hg.mozilla.org/releases/mozilla-beta/rev/4b3d0a8a38cd
Comment 12 Phil Ringnalda (:philor) 2012-09-24 19:33:24 PDT
permaoranged browser_bug538331.js.
Comment 13 Robert Strong [:rstrong] (use needinfo to contact me) 2012-09-24 19:34:35 PDT
Thanks, I should have realized that would happen with the removal of the code it tests. :(
Comment 14 Robert Strong [:rstrong] (use needinfo to contact me) 2012-09-24 19:40:17 PDT
Created attachment 664324 [details] [diff] [review]
Don't run test
Comment 15 Robert Strong [:rstrong] (use needinfo to contact me) 2012-09-24 19:45:02 PDT
Pushed test fix for permaorange.
https://hg.mozilla.org/releases/mozilla-beta/rev/36dc6a850935
Comment 16 Robert Strong [:rstrong] (use needinfo to contact me) 2012-09-24 19:47:06 PDT
Comment on attachment 664324 [details] [diff] [review]
Don't run test

got an rs=dolske over irc
Comment 17 Simona B [:simonab] 2012-10-09 09:30:13 PDT
Verified that the "What's new page" is suppressed when updating to Firefox 16 beta 6 (used the test case from Comment 22 - Bug 789422). 

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.7:
Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0
Mozilla/5.0 (X11; Linux i686; rv:16.0) Gecko/20100101 Firefox/16.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 18 Tracy Walker [:tracy] 2014-01-10 10:41:10 PST
mass remove verifyme requests greater than 4 months old

Note You need to log in before you can comment on or make changes to this bug.