debugger broken in nightly

RESOLVED WORKSFORME

Status

P1
critical
RESOLVED WORKSFORME
6 years ago
5 months ago

People

(Reporter: vlad, Assigned: past)

Tracking

Trunk
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Start today's nightly; open debugger.  No scripts are listed, and in error console:

Timestamp: 9/18/2012 5:01:16 PM
Error: TypeError: this.client is undefined
Source File: chrome://browser/content/debugger-controller.js
Line: 183

Timestamp: 9/18/2012 5:01:21 PM
Error: TypeError: this._allowConnection is not a function
Source File: chrome://global/content/devtools/dbg-server.js
Line: 232

Timestamp: 9/18/2012 5:01:28 PM
Error: TypeError: DebuggerController.activeThread is undefined
Source File: chrome://browser/content/debugger-view.js
Line: 1777
It works fine for me. Can you try starting the debugger with plugins disabled?
This sounds like a pretty awful thing.
But it also works for me, and from the errors posted it doesn't look like a race condition. Maybe an incomplete build? I can't easily imagine a scenario where those errors would heisenhappen.
vlad, check your addons. Do you have an older version of the Profiler installed perhaps? None of us can reproduce currently.
Priority: -- → P1
Assignee: nobody → past
Nope, clean profile, oddly enough.. I stupidly nuked it and created another clean profile, and it works now.  Bleh. :/  Will reopen if I can reproduce it, perhaps with a saved profile.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.