Share menu items should be displayed in custom menu

VERIFIED FIXED in Firefox 18

Status

()

Firefox for Android
Theme and Visual Design
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: sriram, Assigned: sriram)

Tracking

unspecified
Firefox 18
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox18 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Share menu items are displayed in an ActivityChooser given by Android.
1. It's start a new activity -- which puts ours into onPause().
2. It doesn't follow our theme.

It's better to show the list in our custom menu.
(Assignee)

Comment 1

5 years ago
Created attachment 662327 [details] [diff] [review]
Patch

This patch show the share menu items in our custom list.
This is enabled only for 11+, as we support custom menu only there. Gingerbread phones show the activity chooser.

There is a bit of cleanup. I felt a menu item listener needn't do "closeOptionsMenu()". So, the menu item will pass on the event to parent Menu, which will do the necessary cleanups. The Menu will call the listener directly in this case.
Attachment #662327 - Flags: review?(mark.finkle)
(Assignee)

Updated

5 years ago
Blocks: 785994
(Assignee)

Comment 2

5 years ago
Created attachment 662362 [details] [diff] [review]
Patch (1/2): Share

The previous patch missed an animation. It's now added.
Attachment #662327 - Attachment is obsolete: true
Attachment #662327 - Flags: review?(mark.finkle)
Attachment #662362 - Flags: review?(mark.finkle)
(Assignee)

Comment 3

5 years ago
Created attachment 662363 [details] [diff] [review]
Patch (2/2): Sort

This patch (tries to) sorts the list based on the preferredOrder. I don't know how that works. Probably android keeps a history of sharing, and increases the count or something. But my initial test gave 0 for all entries. We could try having it and see if order changes over time.
Attachment #662363 - Flags: review?(mark.finkle)
Attachment #662362 - Flags: review?(mark.finkle) → review+
Attachment #662363 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/2c3416b05490
https://hg.mozilla.org/mozilla-central/rev/d71ef24d5b56
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
(Assignee)

Comment 6

5 years ago
Comment on attachment 662362 [details] [diff] [review]
Patch (1/2): Share

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature
User impact if declined: Share will be same old activity, and wouldnt be a part of submenu.
Testing completed (on m-c, etc.): Landed on m-c on 09/19
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #662362 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 7

5 years ago
Comment on attachment 662363 [details] [diff] [review]
Patch (2/2): Sort

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature.
User impact if declined: Share list (may be) sorted.
Testing completed (on m-c, etc.): Landed on m-c on 09/19
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #662363 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Assignee: nobody → sriram

Comment 8

5 years ago
Comment on attachment 662362 [details] [diff] [review]
Patch (1/2): Share

[Triage Comment]
This would need to be a product request for uplift, since it could cause a regression (we're skeptical of the risk evaluation here).
Attachment #662362 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora-

Updated

5 years ago
Attachment #662363 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora-
Product is requesting uplift for 17, please.
Share option was added in custom menu for the latest Nightly. Closing bug as verified fixed on:

Firefox 18.0a1 (2012-09-24)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
status-firefox18: --- → verified
You need to log in before you can comment on or make changes to this bug.