Closed Bug 792273 Opened 7 years ago Closed 7 years ago

Custom menu should use android's namespace

Categories

(Firefox for Android :: Toolbar, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 18
Tracking Status
firefox18 --- verified

People

(Reporter: sriram, Assigned: sriram)

References

Details

Attachments

(1 file)

Custom menu has all attributes defined in Gecko namespace. This results in menu item tags like

<item gecko:id="@some_id"
      gecko:title="@some_title"/>

Instead, it should use android namespace, to be consistent with other files.
Blocks: 785994
Attached patch PatchSplinter Review
(Aaaaaaaaaahhhhhhhh!!!)
I was under the impression that since android.R.styleable, we need to create similar attributes in attrs.xml. Which means, we need to have our own namespace to use these attributes.

I found that, we can create a shadow copy of attributes in our attrs.xml, using android namespace.

<declare-styleable MyAwesomeMenu>
  <attr name="android:id"/>
</declare-styleable>

"Find and Replace"d all "gecko:" instances in our custom menu related XML files.
Attachment #662351 - Flags: review?(mark.finkle)
Attachment #662351 - Flags: review?(mark.finkle) → review+
Comment on attachment 662351 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Clean up as a part of new feature.
User impact if declined: None. No visible changes to user.
Testing completed (on m-c, etc.): Landed on m-i on 09/20
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None.
Attachment #662351 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/1d109159eb08
Assignee: nobody → sriram
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Comment on attachment 662351 [details] [diff] [review]
Patch

[Triage Comment]
Approving for Aurora so that future patches that build on this apply cleanly and this carries no risk.
Attachment #662351 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product is requesting uplift for 17, please (in case it's also required for this bug!)
Code changes were applied on the latest Nightly. Closing bug as verified fixed on:

Firefox 18.0a1 (2012-09-24)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
Justin@ORION /d/sources/mozilla-aurora
$ hg transplant -s http://hg.mozilla.org/mozilla-central 1d109159eb08
searching for changes
applying 1d109159eb08
patching file mobile/android/base/GeckoMenuInflater.java
Hunk #3 succeeded at 131 with fuzz 2 (offset -17 lines).
patching file mobile/android/base/resources/menu-large-v11/browser_app_menu.xml.in
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file mobile/android/base/resources/menu-large-v11/browser_app_menu.x
ml.in.rej
patching file mobile/android/base/resources/menu-v11/browser_app_menu.xml.in
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file mobile/android/base/resources/menu-v11/browser_app_menu.xml.in.
rej
patching file mobile/android/base/resources/menu-xlarge-v11/browser_app_menu.xml.in
Hunk #1 FAILED at 0
1 out of 1 hunks FAILED -- saving rejects to file mobile/android/base/resources/menu-xlarge-v11/browser_app_menu.
xml.in.rej
patch failed to apply
abort: Fix up the merge and run hg transplant --continue
You need to log in before you can comment on or make changes to this bug.