Open tab menu wider

VERIFIED FIXED in Firefox 19

Status

()

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: ibarlow, Assigned: lucasr)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 19
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Created attachment 662566 [details]
mockup

The tab tray should stretch open a little wider to reveal more tab content. A mockup is attached here.
(Reporter)

Updated

6 years ago
Blocks: 795401
(Assignee)

Comment 1

6 years ago
Created attachment 667505 [details] [diff] [review]
Add more vertical space for the tabs tray on phones
Attachment #667505 - Flags: review?(sriram)
(Assignee)

Updated

6 years ago
Assignee: nobody → lucasr.at.mozilla
OS: Mac OS X → Android
Hardware: x86 → All
(Assignee)

Comment 2

6 years ago
Comment on attachment 667505 [details] [diff] [review]
Add more vertical space for the tabs tray on phones

Oops, submitted too soon. Sorry for the spam.
Attachment #667505 - Attachment is obsolete: true
Attachment #667505 - Flags: review?(sriram)
(Assignee)

Comment 3

6 years ago
Created attachment 668478 [details] [diff] [review]
Add more vertical space for the tabs tray on phones
Attachment #668478 - Flags: review?(sriram)
Comment on attachment 668478 [details] [diff] [review]
Add more vertical space for the tabs tray on phones

This looks good to me.
Attachment #668478 - Flags: review?(sriram) → review+
https://hg.mozilla.org/mozilla-central/rev/d16548ef9acc
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19

Comment 7

6 years ago
Created attachment 671846 [details]
Screenshot

Build ID: 19.0 (2012-10-16) Nightly Channel
Device: Samsung Galaxy Nexus
OS: Android 4.1

Now the page content and URL are smaller. Setting the bug to Verified Fixed.

Updated

6 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Comment 8

6 years ago
Comment on attachment 668478 [details] [diff] [review]
Add more vertical space for the tabs tray on phones

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: Currently, we allow only a couple of tabs to show up when the tabs tray is open. This patch allows more tabs to be visible at once. Improves tab switching UX.
Testing completed (on m-c, etc.): It's been in m-c for a few weeks now, no issues.
Risk to taking this patch (and alternatives if risky): Low, well tested in m-c.
String or UUID changes made by this patch: none
Attachment #668478 - Flags: approval-mozilla-aurora?
Comment on attachment 668478 [details] [diff] [review]
Add more vertical space for the tabs tray on phones

As discussed offline with Lucas and Release Management team, we will have the enitire tab UX improvements ride the trains.
Attachment #668478 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora-
You need to log in before you can comment on or make changes to this bug.