If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Msg compose window won't come up if LDAP autocompletion prefs is turn on

VERIFIED FIXED in mozilla0.9.1

Status

MailNews Core
Composition
P1
major
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Jean-Francois Ducarroz, Assigned: Jean-Francois Ducarroz)

Tracking

(Blocks: 1 bug)

Trunk
mozilla0.9.1
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
This append only when I use a migrated profile and select a migrated LDAP 
directory. Once you have selected a LDAP server in the global prefs dialog, you 
cannot open the compose window because of a JS error due to a missing pref. This 
will still append even if I turn off LDAP autocomplete and the ldap directory 
still set to  one of those migrated server.

Comment 1

17 years ago
reassigning to srilatha and nominating
Assignee: ducarroz → srilatha
Keywords: nsbeta1
(Assignee)

Comment 2

17 years ago
Created attachment 33456 [details] [diff] [review]
proposed fix
(Assignee)

Comment 3

17 years ago
This patch fixes two problems:
1) catch error if a pref is missing which would cause the window to not come up
2) avoid to instanciate a ldap session if ldap is turn off

Srilatha, can you review it?
Assignee: srilatha → ducarroz
(Assignee)

Updated

17 years ago
Whiteboard: Have fix

Comment 4

17 years ago
marking nsbeta1+
Priority: -- → P1
Whiteboard: Have fix → [nsbeta1+]Have fix
Target Milestone: --- → mozilla0.9.1

Comment 5

17 years ago
Looks good to me.
r=srilatha

Updated

17 years ago
Blocks: 17880

Updated

17 years ago
QA Contact: esther → yulian
sr=sspitzer

thanks for fixing this, ducarroz.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 7

17 years ago
Fixed and checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Updated

17 years ago
Whiteboard: [nsbeta1+]Have fix → [nsbeta1+]

Comment 8

17 years ago
*** Bug 79553 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Verified with 2001052404 Wins build
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.