Status

Fennec Graveyard
General
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: hiro, Assigned: hiro)

Tracking

({crash, regression})

Trunk
Firefox 18
ARM
Android
crash, regression
Bug Flags:
in-testsuite -

Details

(Whiteboard: [mobile-crash][startupcrash])

Attachments

(1 attachment)

Due to bug 756504.

09-20 09:54:13.135 W/System.err(  691): java.lang.NoSuchFieldError: no field with name='mDomKeyLocation' signature='I' in class Lorg/mozilla/gecko/GeckoEvent;
09-20 09:54:13.135 W/System.err(  691): 	at org.mozilla.gecko.GeckoAppShell.nativeInit(Native Method)
09-20 09:54:13.145 W/System.err(  691): 	at org.mozilla.gecko.GeckoAppShell.nativeInit(Native Method)
09-20 09:54:13.145 W/System.err(  691): 	at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:392)
09-20 09:54:13.145 W/System.err(  691): 	at org.mozilla.gecko.GeckoApp$2.run(GeckoApp.java:294)
09-20 09:54:13.145 F/libc    (  691): Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1), thread 707 (Thread-81)
Created attachment 662765 [details] [diff] [review]
quick fix

There are lots of duplicated codes between mobile/android/base/GeckoEvent.java and embedding/android/GeckoEvent.java. I am not sure mobile/xul is supported these days, if it is supported those codes should be unified...
Attachment #662765 - Flags: review?
Attachment #662765 - Flags: review? → review?(cpeterson)
(In reply to Hiroyuki Ikezoe (:hiro) from comment #1)
> Created attachment 662765 [details] [diff] [review]
> quick fix
> 
> There are lots of duplicated codes between
> mobile/android/base/GeckoEvent.java and embedding/android/GeckoEvent.java. I
> am not sure mobile/xul is supported these days, if it is supported those
> codes should be unified...

We should be dropping support for mobile/xul and embedding/android. In fact, we might be refactoring embedding/android to handle other bits of code.

Hiroyuki - How are you hitting this crash? What build are you using? Maybe you are making an unsupported build?
(In reply to Mark Finkle (:mfinkle) from comment #2)

> Hiroyuki - How are you hitting this crash? What build are you using? Maybe
> you are making an unsupported build?

Building Thunderbird with mobile/xul. ;-)
(In reply to Hiroyuki Ikezoe (:hiro) from comment #3)
> (In reply to Mark Finkle (:mfinkle) from comment #2)
> 
> > Hiroyuki - How are you hitting this crash? What build are you using? Maybe
> > you are making an unsupported build?
> 
> Building Thunderbird with mobile/xul. ;-)

Why am I not surprised :)

If this patch works for you and Chris thinks it covers the changes made by bug 756504, I am fine with someone landing this. We should be moving toward a code refactor where you could build Thunderbird, or any Mozilla based app, on Android. Eventually, we'll get there.
(In reply to Mark Finkle (:mfinkle) from comment #4)
> (In reply to Hiroyuki Ikezoe (:hiro) from comment #3)
> > (In reply to Mark Finkle (:mfinkle) from comment #2)
> > 
> > > Hiroyuki - How are you hitting this crash? What build are you using? Maybe
> > > you are making an unsupported build?
> > 
> > Building Thunderbird with mobile/xul. ;-)
> 
> Why am I not surprised :)
> 
> If this patch works for you and Chris thinks it covers the changes made by
> bug 756504, I am fine with someone landing this. We should be moving toward
> a code refactor where you could build Thunderbird, or any Mozilla based app,
> on Android. Eventually, we'll get there.

Great! I am glad to hear that.
Just watned to say Hiroyuki-san, you're my hero.  Thunderbird! \o/

Updated

5 years ago
Blocks: 756504
Severity: normal → critical
Keywords: crash, regression
Whiteboard: [mobile-crash][startupcrash]

Updated

5 years ago
Assignee: nobody → hiikezoe
Comment on attachment 662765 [details] [diff] [review]
quick fix

Review of attachment 662765 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. Thanks, Hiroyuki! :)
Attachment #662765 - Flags: review?(cpeterson) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Pushed to Try since I don't see any results posted here. I'll land it if it goes green.
https://tbpl.mozilla.org/?tree=Try&rev=b6377046bd34

Also, Hiro, to make life easier for those committing on your behalf, please make sure your patches include all the necessary commit information in them. Thanks!
https://developer.mozilla.org/en-US/docs/Creating_a_patch_that_can_be_checked_in
(In reply to Ryan VanderMeulen from comment #8)
> https://tbpl.mozilla.org/?tree=Try&rev=b6377046bd34

Green on Try (the Win7 m-oth failure was not from this).
https://hg.mozilla.org/integration/mozilla-inbound/rev/1d44fb1eef16
Flags: in-testsuite-
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1d44fb1eef16
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
You need to log in before you can comment on or make changes to this bug.