Closed Bug 792689 Opened 8 years ago Closed 7 years ago

Add some double negations to the macros in Likley.h

Categories

(Core :: MFBT, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: Ms2ger, Assigned: Ms2ger)

References

Details

Attachments

(1 file)

Attached patch Patch v1Splinter Review
Mats took issue with them in bug 792180 comment 1.
Attachment #662846 - Flags: review?(jwalden+bmo)
Attachment #662846 - Flags: review?(jwalden+bmo) → review+
https://hg.mozilla.org/mozilla-central/rev/6a2d1a3556b9
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
I backed this out because it was the only thing in the MaxHeap regression ranges on both m-c and m-i, but the numbers didn't go back down, so this can reland.

http://hg.mozilla.org/integration/mozilla-inbound/rev/dd72607cee2f
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://hg.mozilla.org/mozilla-central/rev/7ffcbd67d18d
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.