Closed Bug 792729 Opened 12 years ago Closed 12 years ago

MPL 2 upgrade: l10n for et

Categories

(Mozilla Localizations :: et / Estonian, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gerv, Assigned: gerv)

References

Details

Attachments

(1 file)

This language needs some or all of its l10n files to be upgraded to the MPL 2 licence. The current status in the aurora repo http://hg.mozilla.org/releases/l10n/mozilla-aurora/ is:

Summary of Licenses in Files
============================
 Number  Percent License
------- -------- -----------
    366   58.47% <none found>
    157   25.08% mpl/gpl/lgpl (standard block)
     91   14.54% mpl2
     11    1.76% <unknown license>
      1    0.16% pd
----------------------------
    626 files processed

I have a script which can do the relicensing automatically. I will provide a patch here. Once a patch has been provided, please commit it as soon as possible. The aim is to have the relicensing finished by the end of September.

Thanks :-)

Gerv
Attached patch Patch v.1Splinter Review
Attachment #662935 - Flags: review?
Assignee: gerv → nobody
Patched (http://hg.mozilla.org/releases/l10n/mozilla-aurora/et/rev/ae8c06ab4533) can you rerun your check?
Assignee: nobody → gerv
Confirmed - thank you :-)

Gerv
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Sorry, I'll have to re-open this.

The wikipedia plugins cause xml parsing errors, likely because there's a BOM right before <SearchPlugin, which is now in the middle of the file.

Feel free to fix this without an explicit patch, if that's the only three bytes you're touching, that is. The MPL comment should stay as is.

this affects both browser and mail.

You can open the xml file in firefox from file, and if it comes up without a parsing error, you're good.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Fixed in http://hg.mozilla.org/releases/l10n/mozilla-aurora/et/rev/bbd94d11218f
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
Attachment #662935 - Flags: review? → review+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: