Closed Bug 792846 Opened 7 years ago Closed 7 years ago

SystemMessageInternal.js fails if one of the message receiver is closed

Categories

(Core :: DOM: Core & HTML, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18
blocking-basecamp +

People

(Reporter: vingtetun, Assigned: gwagner)

References

Details

(Keywords: regression)

Attachments

(1 file)

If you open the dialer and then close it manually you won't receive calls anymore.

E/GeckoConsole(  105): [JavaScript Error: "NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIMessageSender.sendAsyncMessage]" {file: "jar:file:///system/b2g/omni.ja!/components/SystemMessageInternal.js" line: 82}]


This is a regression from bug 777206. Adding a simple try/cacth around the content of the broadcast message fix the issue but it seems like one of the listener of the message should have been removed from the list where it has not been.
blocking-basecamp: ? → +
Keywords: regression
Gregor, can you take this?
Assignee: nobody → anygregor
Attached patch patchSplinter Review
Depends on: 793361
Gregor, do you wait for a review or are you going to do a cleaner fix that relies on unregistering listeners by sending a message when the process is closed / crash.
(In reply to Vivien Nicolas (:vingtetun) from comment #3)
> Gregor, do you wait for a review or are you going to do a cleaner fix that
> relies on unregistering listeners by sending a message when the process is
> closed / crash.

So the problem is that we never unregister any message listeners because of bug 793361. so the only clean solution is bug 777508. philikon is working on it but we might want to use the workaround as well.
Attachment #663553 - Flags: review?(fabrice)
Attachment #663553 - Flags: review?(21)
Comment on attachment 663553 [details] [diff] [review]
patch

Review of attachment 663553 [details] [diff] [review]:
-----------------------------------------------------------------

I don't like the workaround but I can live with it until there is a proper fix. Can you add a comment in the code explaining that this should be removed once the other bugs lands?
Attachment #663553 - Flags: review?(21) → review+
Attachment #663553 - Flags: review?(fabrice)
Duplicate of this bug: 793174
https://hg.mozilla.org/mozilla-central/rev/8f0b50af1051
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.