Auto-complete downgrades to http (from https)

RESOLVED DUPLICATE of bug 781617

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 781617
5 years ago
5 years ago

People

(Reporter: ashkan.soltani, Unassigned)

Tracking

15 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Tested on Firefox 15.0.1 - 

If user has previously visited a site via HTTP (i.e http://google.com), subsequent attempts to visit https://google.com will redirect the user to the NON-HTTPS version of the site. 

This can be worked-around by adding extra characters (i.e /?) to the URL but otherwise, unsophisticated users would inadvertently be downgraded to HTTP even though they intend to use HTTPS.

This seems related to Bug #720081 (which is marked 'fixed') but problem persists.
see bug 76999 and bug 781617

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 781617
You need to log in before you can comment on or make changes to this bug.