Last Comment Bug 793088 - Startup failure in localization builds since Aurora17.0a2 20120920042010
: Startup failure in localization builds since Aurora17.0a2 20120920042010
Status: RESOLVED FIXED
[buildduty]
:
Product: Release Engineering
Classification: Other
Component: General Automation (show other bugs)
: other
: x86 All
-- blocker (vote)
: ---
Assigned To: Rail Aliiev [:rail] ⌚️ET
: Chris AtLee [:catlee]
:
Mentors:
: 793101 793149 793164 793200 793207 (view as bug list)
Depends on: 772446
Blocks: 793379
  Show dependency treegraph
 
Reported: 2012-09-20 22:55 PDT by Alice0775 White
Modified: 2013-08-12 21:54 PDT (History)
23 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
+
fixed


Attachments
fix v1 (1.89 KB, patch)
2012-09-21 08:28 PDT, Rail Aliiev [:rail] ⌚️ET
catlee: review+
rail: checked‑in+
Details | Diff | Splinter Review

Description User image Alice0775 White 2012-09-20 22:55:18 PDT
Steps to reproduce:
1. Insatall http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-09-20-04-20-10-mozilla-aurora-l10n/firefox-17.0a2.ja.win32.zip
2. Start Firefox with clean profile

Actual results:
  Startup failure

XML パースエラー: 定義されていない実体が使用されています。
URL: chrome://browser/content/browser.xul
行番号: 540, 列番号: 9:        <button default="true"
--------^


Regression Pushlog:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=006174be2306&tochange=eb69897f7d24
Comment 1 User image Semtex 2012-09-21 01:04:23 PDT
Similar thing happen with l10n Nightly 18a:
"XML parsing error: undefined entity
Area: chrome://browser/content/browser.xul
Line Number: 1630, column 13:
<menuitem id="appmenu_sync-tabs"

Startup failure, problem reported also here: http://forums.mozillazine.org/viewtopic.php?f=23&t=2550911
Comment 2 User image Alice0775 White 2012-09-21 02:02:41 PDT
Download from http://www.mozilla.jp/firefox/preview/ and install.
Aurora fails to start up and I get same error in comment#0

So I change mportance to blocker
Comment 3 User image Alice0775 White 2012-09-21 02:03:00 PDT
s/mportance/Importance/
Comment 4 User image Raul Malea 2012-09-21 05:34:01 PDT
Same bug for romanian build.
Comment 5 User image Alexander L. Slovesnik 2012-09-21 05:45:01 PDT
Sounds like this bug affects more than one locale. CC'ing Axel.
Comment 6 User image Axel Hecht [:Pike] 2012-09-21 06:14:42 PDT
I don't know what's going on, the regression range in comment 0 isn't it.

Over to releng to see if there is something in the automation going wrong. Right now, the behaviour indicates is spanning locales and branches.
Comment 7 User image Axel Hecht [:Pike] 2012-09-21 06:40:42 PDT
So, the culprit seems to be the following:

 argv: ['make', u'installers-de', 'LOCALE_MERGEDIR=$PWD/merged']

ends up as

/builds/slave/m-cen-osx64-l10n-ntly/build/mozilla-central/_virtualenv/bin/python ../../config/JarMaker.py \
	   -j ../../dist/xpi-stage/locale-de/chrome \
	  -t ../.. -f symlink  --both-manifests -c WD/merged/netwerk -c /builds/slave/m-cen-osx64-l10n-ntly/build/l10n-central/de/netwerk -c ../../netwerk/locales/en-US -DNDEBUG -DTRIMMED -DAB_CD=de -DXPI_NAME=locale-de -DX_DISPLAY_MISSING=1 -DHAVE_64BIT_OS=1 -DJSGC_INCREMENTAL=1 -DMOZ_ENABLE_PROFILER_SPS=1 -DMOZILLA_VERSION=\"18.0a1\" -DMOZILLA_VERSION_U=18.0a1 -DMOZILLA_UAVERSION=\"18.0\" -DXP_MACOSX=1 -DXP_DARWIN=1 -DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_STDCALL=1 -DHAVE_SSIZE_T=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1 -DHAVE_UINT=1 -DHAVE_VISIBILITY_HIDDEN_ATTRIBUTE=1 -DHAVE_VISIBILITY_ATTRIBUTE=1 -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_X11_XKBLIB_H=1 -DHAVE_MMINTRIN_H=1 -DHAVE_SYS_CDEFS_H=1 -DHAVE_DLADDR=1 -DHAVE_MEMMEM=1 -DNO_X11=1 -DHAVE_RANDOM=1 -DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DHAVE_STAT64=1 -DHAVE_LSTAT64=1 -DHAVE_SETBUF=1 -DHAVE_ISATTY=1 -DHAVE_FLOCKFILE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STRTOK_R=1 -DHAVE_LANGINFO_CODESET=1 -DVA_COPY=va_copy -DHAVE_VA_COPY=1 -DHAVE_VA_LIST_AS_ARRAY=1 -DMALLOC_H=\<malloc/malloc.h\> -DHAVE_STRNDUP=1 -DHAVE_I18N_LC_MESSAGES=1 -DHAVE_LOCALECONV=1 -DNS_ALWAYS_INLINE=__attribute__\(\(always_inline\)\) -DNS_ATTR_MALLOC=__attribute__\(\(malloc\)\) -DNS_WARN_UNUSED_RESULT=__attribute__\(\(warn_unused_result\)\) -DMOZ_PHOENIX=1 -DMOZ_BUILD_APP=browser -DMOZ_WIDGET_COCOA=1 -DMOZ_INSTRUMENT_EVENT_LOOP=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DIBMBIDI=1 -DACCESSIBILITY=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_WEBRTC=1 -DMOZ_SAMPLE_TYPE_FLOAT32=1 -DMOZ_RAW=1 -DMOZ_OGG=1 -DATTRIBUTE_ALIGNED_MAX=64 -DMOZ_WEBM=1 -DMOZ_MEDIA_NAVIGATOR=1 -DMOZ_VP8=1 -DMOZ_VP8_ERROR_CONCEALMENT=1 -DMOZ_VP8_ENCODER=1 -DVPX_X86_ASM=1 -DMOZ_WAVE=1 -DMOZ_SYDNEYAUDIO=1 -DMOZ_SPEEX_RESAMPLER=1 -DMOZ_CUBEB=1 -DMOZ_MEDIA=1 -DMOZ_VORBIS=1 -DMOZ_OPUS=1 -DMOZ_XTF=1 -DENABLE_SYSTEM_EXTENSION_DIRS=1 -DMOZ_CRASHREPORTER=1 -DMOZ_CRASHREPORTER_ENABLE_PERCENT=100 -DLIBJPEG_TURBO_X64_ASM=1 -DMOZ_WEBAPP_RUNTIME=1 -DMOZ_SIGNING=1 -DMOZ_UPDATER=1 -DMOZ_UPDATE_CHANNEL=nightly -DMOZ_FEEDS=1 -DMOZ_SAFE_BROWSING=1 -DMOZ_URL_CLASSIFIER=1 -DMOZ_DEBUG_SYMBOLS=1 -DMOZ_LOGGING=1 -DSIZEOF_INT_P=8 -DMOZ_MEMORY_SIZEOF_PTR_2POW=3 -DMOZ_MEMORY=1 -DMOZ_MEMORY_DARWIN=1 -DJSGC_INCREMENTAL=1 -DHAVE___CXA_DEMANGLE=1 -DHAVE__UNWIND_BACKTRACE=1 -DJS_DEFAULT_JITREPORT_GRANULARITY=3 -DMOZ_OMNIJAR=1 -DMOZ_USER_DIR=\"Mozilla\" -DMOZ_STATIC_JS=1 -DMOZ_TREE_PIXMAN=1 -DHAVE_STDINT_H=1 -DHAVE_INTTYPES_H=1 -DMOZ_TREE_CAIRO=1 -DHAVE_UINT64_T=1 -DMOZ_GRAPHITE=1 -DMOZ_ENABLE_SKIA=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DBUILD_CTYPES=1 -DMOZ_PLACES=1 -DMOZ_SERVICES_AITC=1 -DMOZ_SERVICES_NOTIFICATIONS=1 -DMOZ_SERVICES_SYNC=1 -DMOZ_MACBUNDLE_ID=org.mozilla.nightly -DMOZ_APP_UA_NAME=\"\" -DMOZ_APP_UA_VERSION=\"18.0a1\" -DFIREFOX_VERSION=18.0a1 -DMOZ_DLL_SUFFIX=\".dylib\" -DXP_UNIX=1 \
	  ../../netwerk/locales/jar.mn

that is, $PWD is expanded to WD. No idea why that'd be the case, though.

Also, verified on mac nightly german.
Comment 8 User image Johan C 2012-09-21 06:59:07 PDT
*** Bug 793101 has been marked as a duplicate of this bug. ***
Comment 9 User image Chris AtLee [:catlee] 2012-09-21 07:00:10 PDT
my guess is that this isn't being run through the shell, so $PWD isn't expanded as a bash variable. Then make sees is, and expands $P to "" and you're left with "WD".
Comment 10 User image Siddharth Agarwal [:sid0] (inactive) 2012-09-21 07:04:02 PDT
That should be something like ['sh', '-c', u'make installers-de LOCALE_MERGEDIR=$PWD/merged'].
Comment 11 User image Chris AtLee [:catlee] 2012-09-21 07:10:40 PDT
this is fallout from http://hg.mozilla.org/build/buildbotcustom/diff/a1389c53fede/process/factory.py#l1.1328
Comment 12 User image Matthias Versen [:Matti] 2012-09-21 07:44:05 PDT
*** Bug 793164 has been marked as a duplicate of this bug. ***
Comment 13 User image Matthias Versen [:Matti] 2012-09-21 07:44:38 PDT
*** Bug 793149 has been marked as a duplicate of this bug. ***
Comment 14 User image Rail Aliiev [:rail] ⌚️ET 2012-09-21 08:28:16 PDT
Created attachment 663411 [details] [diff] [review]
fix v1
Comment 15 User image Rail Aliiev [:rail] ⌚️ET 2012-09-21 08:49:24 PDT
Comment on attachment 663411 [details] [diff] [review]
fix v1

http://hg.mozilla.org/build/buildbotcustom/rev/5cbe849d41c6
Comment 16 User image Chris AtLee [:catlee] 2012-09-21 09:43:09 PDT
we disabled nightly and aurora updates around 07:52 PT
Comment 17 User image Alexander L. Slovesnik 2012-09-21 09:53:30 PDT
*** Bug 793200 has been marked as a duplicate of this bug. ***
Comment 18 User image Alexander L. Slovesnik 2012-09-21 09:54:56 PDT
*** Bug 793207 has been marked as a duplicate of this bug. ***
Comment 19 User image Raul Malea 2012-09-21 11:36:15 PDT
Error for romanian language: Eroare la analiza XML: entitate nedefinită
Adresă: chrome://browser/content/browser.xul
Număr linie 246, coloană 5:    <broadcaster id="devtoolsMenuBroadcaster_DevToolbar"
----^
Comment 20 User image Rail Aliiev [:rail] ⌚️ET 2012-09-21 11:49:31 PDT
The patch worked, need to trigger a nightly build (will do in a bit).
Comment 21 User image Rail Aliiev [:rail] ⌚️ET 2012-09-22 04:08:13 PDT
Could somebody download and verify if the nightlies are ok?
Comment 22 User image Alexander L. Slovesnik 2012-09-22 05:57:07 PDT
(In reply to Rail Aliiev [:rail] from comment #21)
> Could somebody download and verify if the nightlies are ok?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central-l10n/firefox-18.0a1.ru.linux-i686.tar.bz2 works for me.
Russian Windows build for central still shows the error. Apparently it's been build before patch has been checked in and not respinned.
Comment 23 User image Axel Hecht [:Pike] 2012-09-22 06:13:02 PDT
The l10n nightlies are still not all done yet, and windows seems to be even waiting on the en-US nightly to finish still.
Comment 24 User image Semtex 2012-09-22 11:00:54 PDT
(In reply to Rail Aliiev [:rail] from comment #21)
> Could somebody download and verify if the nightlies are ok?

Polish Nightly 18, working again without problem.
Comment 25 User image Raul Malea 2012-09-22 11:12:17 PDT
Now, romanian build win32 for Nightly working. Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120922030540 . Built from http://hg.mozilla.org/mozilla-central/rev/9cfb80a82883
Comment 26 User image Jake 2012-09-22 11:16:18 PDT
Shouldn't this bug affect all localization builds? Im very curious why some languages were totally fine. Like zh-CN and zh-TW are basically the same language, but ont was broken, one was ok.
Comment 27 User image Axel Hecht [:Pike] 2012-09-22 11:59:55 PDT
This bug affected code paths with strings missing in existing files. Depending on which strings would miss, this could break on start-up, or at some point, or, not at all, for totally complete or just as well for totally incomplete localizations.
Comment 28 User image Jake 2012-09-22 12:22:58 PDT
Thanks for the explanation, good to know.
Comment 29 User image Mad Goldfish 2012-09-23 04:14:03 PDT
Latest en-GB nightly fixed it for me.
Comment 30 User image Axel Hecht [:Pike] 2012-09-23 05:32:14 PDT
Marking FIXED per reports here, and inspection of some of the build logs. Let's use bug 793379 to track the updates.
Comment 31 User image Alex Keybl [:akeybl] 2012-09-24 16:25:18 PDT
(In reply to Rail Aliiev [:rail] from comment #15)
> Comment on attachment 663411 [details] [diff] [review]
> fix v1
> 
> http://hg.mozilla.org/build/buildbotcustom/rev/5cbe849d41c6

Marking FF17 as fixed, please correct if wrong.
Comment 32 User image Mad Goldfish 2012-09-25 01:59:24 PDT
Does not work in Aurora 17.0a2, Fixed in Nightly 18.0a1
Comment 33 User image Justin Wood (:Callek) [away until Feb 27] 2012-09-25 02:02:39 PDT
(In reply to Mad Goldfish from comment #32)
> Does not work in Aurora 17.0a2, Fixed in Nightly 18.0a1

Please give much more specific information, which aurora build did you have, which is the broken one, how did you update, and what do you mean by "does not work". Thanks
Comment 34 User image Mad Goldfish 2012-09-25 02:20:56 PDT
Bug, as originally reported, exists in FF17.0a2 (Aurora) - which is the current download on the mozilla.org website, and FF will only display the English version of XML parse error shown in the description.

FF18.0a1 (Nightly) from 2012-09-25 starts up normally as expected, and does not show the issue.

Both on Windows 7 using en-GB locale
Comment 35 User image Axel Hecht [:Pike] 2012-09-25 06:02:13 PDT
20120924042009 en-GB on aurora, win 7 works for me.

Note You need to log in before you can comment on or make changes to this bug.