Closed Bug 793213 Opened 7 years ago Closed 7 years ago

Mochitests broken on B2G

Categories

(Firefox OS Graveyard :: General, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-basecamp:+)

RESOLVED FIXED
blocking-basecamp +

People

(Reporter: jgriffin, Assigned: jgriffin)

References

Details

Attachments

(1 file)

Mochitests are broken on B2G as of https://hg.mozilla.org/mozilla-central/pushloghtml?startID=23497&endID=23498; the tests never navigate to the starting mochitest page.

I'm guessing this is fallout from bug 777145, which landed in that merge from inbound.

In that bug, a change (https://hg.mozilla.org/mozilla-central/rev/2c8cb9b79705) was made to Marionette to disable offline status management; I'm guessing we need to inject similar code into the mochitest (and reftest...) test runners.
blocking-basecamp: --- → ?
Since this blocks all the tests, this is a blocker.  Geo, is this something you could take?  If not, do you have a suggestion for an owner?
Assignee: nobody → gmealer
blocking-basecamp: ? → +
(In reply to Andrew Overholt [:overholt] from comment #1)
> Since this blocks all the tests, this is a blocker.  Geo, is this something
> you could take?  If not, do you have a suggestion for an owner?

I'll investigate if I can get it to work using roughly the same approach as was used for Marionette in bug 777145; if not, I'll punt it upstairs. :)
Assignee: gmealer → jgriffin
This fixes the problem for mochitest.  I haven't tried it for reftest but I think it should fix the problem there too, assuming the same problem exists.
Attachment #663466 - Flags: review?(ahalberstadt)
Depends on: 777145
This is getting iffy, but I guess the workarounds are a necessary evil for now.
Comment on attachment 663466 [details] [diff] [review]
Disable offline mode for mochitest/reftest,

Review of attachment 663466 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good from my point of view, but it isn't clear to me if this was broken intentionally or is a regression. Is there another bug if it's the latter?
Attachment #663466 - Flags: review?(ahalberstadt) → review+
(In reply to Andrew Halberstadt [:ahal] from comment #5)
> This looks good from my point of view, but it isn't clear to me if this was
> broken intentionally or is a regression. Is there another bug if it's the
> latter?

Breaking marionette, mochitests, etc. was not the intention of bug 777145, but an unfortunate side-effect. At this time in the release cycle, we don't have a better way of fixing it than the workarounds posted here. I'm not even sure there's a better permanent fix. In any case, let's worry about this after we ship v1.
xpcshell does it the same way
https://hg.mozilla.org/mozilla-central/rev/034411ee6858
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.