iFrame Sandbox not having allow-top-navigation still allows window.top.location change

RESOLVED DUPLICATE of bug 785310

Status

()

RESOLVED DUPLICATE of bug 785310
6 years ago
6 years ago

People

(Reporter: fastest963, Unassigned)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Changing window.top.location in an iFrame with a sandbox property not containing "allow-top-navigation" is still allowing the change. Bug 341604 adds support for the sandbox attribute and the defined tests check for an anchor tag with target="_top" but does not test window.top.location changes in JS.

Reproduced in Aurora (17.0a2 (2012-09-21)).
(Reporter)

Updated

6 years ago
Blocks: 341604

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 785310
You need to log in before you can comment on or make changes to this bug.