Last Comment Bug 793276 - new android updater downloads on cell data connection without asking
: new android updater downloads on cell data connection without asking
Status: VERIFIED FIXED
: dogfood
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: -- blocker (vote)
: Firefox 18
Assigned To: James Willcox (:snorp) (jwillcox@mozilla.com)
:
Mentors:
: 795705 (view as bug list)
Depends on: 808595
Blocks: 786380
  Show dependency treegraph
 
Reported: 2012-09-21 12:23 PDT by cdlrobinson
Modified: 2016-07-29 14:29 PDT (History)
11 users (show)
ryanvm: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
verified


Attachments
Make sure we do not force an automatic download for Android updates (1.53 KB, patch)
2012-10-01 07:34 PDT, James Willcox (:snorp) (jwillcox@mozilla.com)
mark.finkle: review+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description cdlrobinson 2012-09-21 12:23:45 PDT
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

I dismissed the notification that a download was available since I was not on WiFi and have a limited data plan.


Actual results:

later when I checked my phone there was a notification to install the downloaded update.


Expected results:

The download should not happen over a cell data connection unless I select to download it. 

I would prefer a setting to not even offer the download unless the phone is on WiFi.
Comment 1 Steffen Wilberg 2012-09-23 14:31:47 PDT
Since there's apparently no way to disable the new update service, I had to uninstall Nightly :-(
Comment 2 Aaron Train [:aaronmt] 2012-09-24 07:35:10 PDT
Had this happen to me this morning too as soon as I turned my device on and switched to cellular, the download initiated.
Comment 3 Alex Keybl [:akeybl] 2012-09-24 16:25:54 PDT
Tracking for release, but we'll untrack for versions as the move to beta (which doesn't use the updater).
Comment 4 Aaron Train [:aaronmt] 2012-09-30 08:20:40 PDT
*** Bug 795705 has been marked as a duplicate of this bug. ***
Comment 5 Aaron Train [:aaronmt] 2012-09-30 08:21:28 PDT
From bug 795705: "I have 300 MB monthly data limit. Right now, in the "middle" of the month I used 220 MB out of 300, and Firefox used 136 MB alone, that is more than all other apps combined."
Comment 6 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-01 07:34:40 PDT
Created attachment 666547 [details] [diff] [review]
Make sure we do not force an automatic download for Android updates
Comment 7 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-01 07:43:48 PDT
The "force download" flag that we include in the intent that is used when you accept an update over mobile data was accidentally kept later on when we did a scheduled update check. Attached patch fixes that. Stupid API.
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2012-10-01 07:56:49 PDT
Comment on attachment 666547 [details] [diff] [review]
Make sure we do not force an automatic download for Android updates

Yeah, not the most straight forward API
Comment 9 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-01 08:02:39 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/8c035b44ef28
Comment 10 Ryan VanderMeulen [:RyanVM] 2012-10-01 19:00:57 PDT
https://hg.mozilla.org/mozilla-central/rev/8c035b44ef28

Should this have a test?
Comment 11 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-04 07:34:56 PDT
(In reply to Ryan VanderMeulen from comment #10)
> https://hg.mozilla.org/mozilla-central/rev/8c035b44ef28
> 
> Should this have a test?

No way currently to have an automated test for this, no.

You should be able to reproduce the bug prior to this fix, though, with the following STR:

1) Disable wifi, ensure you have a mobile data connection
2) Go to about:firefox, click 'check for updates' (with an old enough nightly obviously)
3) When prompted, start the update download
4) Swipe to cancel the 'apply update' notification, or cancel the installation after clicking on the notification.
5) Check for updates again, and the download would start automatically.
Comment 12 Cristian Nicolae (:xti) 2012-10-09 06:39:32 PDT
Updates are not downloaded automatically on 3G on the latest Nightly. Each time when STR from comment #11 are performed, the update notification is triggered which it's expected.
Closing bug as verified fixed on:

Firefox 18.0a1 (2012-10-08)
Device: Galaxy Nexus
OS: Android 4.1.1
Comment 13 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-16 15:43:54 PDT
Looks like we still need a beta uplift nom here if we want this to go out with 17.
Comment 14 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-22 11:24:22 PDT
Comment on attachment 666547 [details] [diff] [review]
Make sure we do not force an automatic download for Android updates

[Approval Request Comment]
Low-risk, fixes annoying user-facing update bug
Comment 15 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-22 11:54:10 PDT
Comment on attachment 666547 [details] [diff] [review]
Make sure we do not force an automatic download for Android updates

Definitely worth uplifting this fix to reduce an annoying user-facing issue.
Comment 16 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-10-22 13:03:06 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/518ee633eb9c

Note You need to log in before you can comment on or make changes to this bug.