Last Comment Bug 793359 - jank when opening a google groups page
: jank when opening a google groups page
Status: RESOLVED WORKSFORME
: perf
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows 8
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
https://groups.google.com/forum/?from...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-21 20:09 PDT by timbugzilla
Modified: 2016-03-07 06:55 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
about:support as text file (4.88 KB, text/plain)
2012-09-21 20:09 PDT, timbugzilla
no flags Details

Description timbugzilla 2012-09-21 20:09:27 PDT
Created attachment 663634 [details]
about:support as text file

I experience a few seconds of jank when opening a google groups' group page such as mozilla.dev.platform.

A gecko profiler profile for this is available here:

http://people.mozilla.com/~bgirard/cleopatra/?report=bd345397daed044bf60792452d9c80edb9d4a235

My about:support has been attached as a text file.
Comment 1 Manoj 2012-09-26 07:02:04 PDT
I notice this on x64 Windows 7 on all Google Blogspot blogs that use widgets and default themes.
Comment 2 timbugzilla 2013-02-07 00:26:32 PST
Here's a profile for opening the "my groups" page at google groups.

http://people.mozilla.com/~bgirard/cleopatra/#report=d0d1a2602885fe296ab0d64c6c4be88e27415b2c

Most of the jank period seems to be spent in an Evaluate String operation.

Profile was recorded on an Intel E8500 based machine with win7 x64. 06/02 moz-central nightly win32 build.

https://groups.google.com/forum/#!myforums
Comment 3 mayankleoboy1 2013-02-07 01:02:56 PST
even opening the gmail page for the first time causes ~1-1.5 seconds jank.
Profile :
http://people.mozilla.com/~bgirard/cleopatra/#report=aad761f1529578c57c9fee68ce3ceb8b60288de3

IIRC this is already being tracked in another bug. Should be P1, IMO.
Comment 4 mayankleoboy1 2013-02-07 01:10:56 PST
see also : bug 789598
Comment 5 timbugzilla 2013-02-07 18:22:31 PST
There is also quite a bit of jank when using the "u" keyboard shortcut to return to group page from a thread page. e.g. Go to the moz.dev.platform group:

https://groups.google.com/forum/#!forum/mozilla.dev.platform

Then enter the thread for "How does one debug uninitialized value usage from JavaScript (TB) ?". 

https://groups.google.com/forum/#!topic/mozilla.dev.platform/fEUHUse_qb8

Then press the "u" key to return to the moz.dev.platform group.

I do not see this when using the same keyboard shortcut to return to my inbox in gmail for example. The operation also completes a lot more quickly in Chrome.

The profile is here:

http://people.mozilla.com/~bgirard/cleopatra/#report=a919bc7a8903d32c10c294240efef8f700e9cd9f

Most of the jank time seems to be spent in the JS interpreter.
Comment 6 timbugzilla 2013-02-07 18:24:15 PST
That profile was recorded on an Intel E8500 based machine running todays moz central nightly win32 build, on win7 x64.
Comment 7 mayankleoboy1 2013-02-08 21:08:50 PST
http://people.mozilla.com/~bgirard/cleopatra/#report=c5caf961350d8ccb46dcd8825fc8bc741f023f85

In google groups, switching from "compact list view" to "standard view".
Comment 8 Wayne Mery (:wsmwk, NI for questions) 2015-07-05 16:51:10 PDT
Can you still reproduce?

https://groups.google.com/forum/#!topic/mozilla.dev.platform/fEUHUse_qb8 takes a long time to load. But I do not experience jank. This is with a current nightly and e10s enabled, heavily loaded with 400 tabs

I also cannot reproduce related bug 924001, nor bug 802731
Comment 9 mayankleoboy1 2015-07-06 00:31:58 PDT
with e10s and APZC, this is fine now.
Comment 10 timbugzilla 2015-07-10 03:51:39 PDT
Looks like there is still a little bit of jank (like less than 500 ms), but it is much better.
Comment 11 Wayne Mery (:wsmwk, NI for questions) 2016-03-07 06:55:49 PST
Thanks for the update

Note You need to log in before you can comment on or make changes to this bug.