Last Comment Bug 793455 - DB cache is closing databases too frequently
: DB cache is closing databases too frequently
Status: RESOLVED FIXED
[regression:TB15]
: perf, regression
Product: MailNews Core
Classification: Components
Component: Database (show other bugs)
: Trunk
: All All
: -- major (vote)
: Thunderbird 18.0
Assigned To: Kent James (:rkent)
:
Mentors:
: 793666 (view as bug list)
Depends on: 929281 710056
Blocks: 723248
  Show dependency treegraph
 
Reported: 2012-09-22 16:26 PDT by Kent James (:rkent)
Modified: 2015-02-20 09:05 PST (History)
8 users (show)
rkent: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
+
fixed


Attachments
5 minutes is 300000 milliseconds (1.26 KB, patch)
2012-09-24 11:34 PDT, Kent James (:rkent)
irving: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Splinter Review

Description Kent James (:rkent) 2012-09-22 16:26:22 PDT
See https://bugzilla.mozilla.org/show_bug.cgi?id=710056

--- Comment #151 from David :Bienvenu <mozilla@davidbienvenu.org> 2012-09-22 13:39:47 PDT ---
Kent, I really intended the db's to only get closed after 3 minutes of idle (or
5, I can't remember), not 3 seconds. It was a milliseconds vs. seconds
confusion, so that really should be fixed.
Comment 1 Mark Banner (:standard8) 2012-09-24 05:47:58 PDT
*** Bug 793666 has been marked as a duplicate of this bug. ***
Comment 2 rsx11m 2012-09-24 06:35:27 PDT
Forwarding tracking requests from bug 793666.
Comment 3 Kent James (:rkent) 2012-09-24 11:34:27 PDT
Created attachment 664144 [details] [diff] [review]
5 minutes is 300000 milliseconds
Comment 4 :Irving Reid (No longer working on Firefox) 2012-09-24 12:51:06 PDT
Comment on attachment 664144 [details] [diff] [review]
5 minutes is 300000 milliseconds

Review of attachment 664144 [details] [diff] [review]:
-----------------------------------------------------------------

I don't think we need to worry about people who have overridden this pref, so just changing the default is fine.
Comment 5 Kent James (:rkent) 2012-09-24 20:48:56 PDT
Comment on attachment 664144 [details] [diff] [review]
5 minutes is 300000 milliseconds

Checked in https://hg.mozilla.org/comm-central/rev/246b6dfaf2e7
Comment 6 Mark Banner (:standard8) 2012-09-25 07:59:12 PDT
Comment on attachment 664144 [details] [diff] [review]
5 minutes is 300000 milliseconds

[Triage Comment]
We should just take this straight onto aurora and beta as it should be safe.
Comment 7 Ludovic Hirlimann [:Usul] 2012-09-25 08:00:16 PDT
That will affect new installs only right ?
Comment 8 :Irving Reid (No longer working on Firefox) 2012-09-25 08:02:13 PDT
(In reply to Ludovic Hirlimann [:Usul] from comment #7)
> That will affect new installs only right ?

I'm pretty sure everyone who has not changed the pref will get the new default when they update
Comment 9 Mark Banner (:standard8) 2012-09-25 08:02:50 PDT
(In reply to Irving Reid (:irving) from comment #8)
> (In reply to Ludovic Hirlimann [:Usul] from comment #7)
> > That will affect new installs only right ?
> 
> I'm pretty sure everyone who has not changed the pref will get the new
> default when they update

Correct.
Comment 11 Craig Leres 2013-01-09 11:14:47 PST
(In reply to Irving Reid (:irving) from comment #8) 
> I'm pretty sure everyone who has not changed the pref will get the new
> default when they update

I've been banging this bug for-ever. I never changed mail.db.idle_limit but just now found it set to 4000. I changed it to 300000 and for the first time in *years* thunderbird has stopped locking up randomly.

Note You need to log in before you can comment on or make changes to this bug.