If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Test 10.4.3-1-104.js failure

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
5 years ago
10 months ago

People

(Reporter: David Bruant, Unassigned)

Tracking

(Blocks: 1 bug)

18 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
From test262

function testcase(){
  Object.defineProperty(Object.prototype, "x", { get: function () { "use strict"; return this; } }); 
  if(!((5).x === 5)) return false;
  return true;
}

The issue is that 5 is coerced to an object while it shouldn't.

This should fix Test 10.4.3-1-106 at the same time.
(Reporter)

Updated

5 years ago
Depends on: 652780
(Reporter)

Updated

5 years ago
Blocks: 652780
No longer depends on: 652780
This might be bug 771865. I didn't look at the spec for this, but if getting properties from primitive numbers shouldn't ever coerce to object, then that bug might get a bit easier to implement, too.
(Assignee)

Updated

3 years ago
Assignee: general → nobody

Comment 2

10 months ago
No longer reproducible, resolving as WFM.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.