Firefox under Android : the external keyboard not mapped properly

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: f1jek01, Unassigned)

Tracking

({intl})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Under Android, I use an external USB keyboard which is handled by "external keyboard pro", an application which allows to use a Fr keyboard (in my case).

This keyboard is well seen as AZERTY into a lot of application but not in FF, neither in the address bar nor in the input fields.


Actual results:

Even if it's a Fr-mapped keyboard, FF displays Q instead of A, W instead of Z and so on...


Expected results:

FF should behave like the other apps, including the android browser : follow the external keyboard mapping choosed.
(Reporter)

Updated

6 years ago
Severity: normal → major
Component: Untriaged → General
Keywords: intl
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Component: General → Keyboards and IME
Product: Firefox → Firefox for Android
Version: 15 Branch → unspecified
What device? There is a chance that this may be related to bug 712018.
This sounds like general bug 712018 or related Asus Transformer bug 669361.
(Reporter)

Comment 4

6 years ago
I agree that it's close to bug 712018 but in my case, both the URL bar and the texboxes keyboard mapping are not managed correctly.
(Reporter)

Comment 5

6 years ago
(In reply to Chris Peterson (:cpeterson) from comment #2)
> This sounds like general bug 712018 or related Asus Transformer bug 669361.

Yes Chris. It seems to be the same problem.
f1jek01, what Android device and external keyboard are you using?

I just landed a fix for Asus Transformer bug 669361, so tonight's Nightly build might fix (or change) this bug.
(Reporter)

Comment 7

6 years ago
The keyboard is a Trust Wireless.
The Android device is a Allwinner A10 Cortex A8 1,0 GHz in the shape of a USB key with a HDMI output.
Depends on: 712018
Hey j1jek01, can you verify if Nightly or Aurora has fixed the issue for you? (http://nightly.mozilla.org)
Flags: needinfo?(f1jek01)
(Reporter)

Comment 9

6 years ago
It's OK for the address/search bar (at the top of FF) but for example in the login page of LIVE.FR, the input text fields are still in QWERTY (instead of AZERTY).
Flags: needinfo?(f1jek01)
Jim, is this a dupe? What else needs to be done here to address this?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(nchen)
I don't think it's an exact dupe. I can take a look if it's still a problem.

f1jek01, can you still reproduce this bug using the latest Nightly? (http://nightly.mozilla.org)
Flags: needinfo?(nchen) → needinfo?(f1jek01)
(Reporter)

Comment 12

6 years ago
Will try shortly.
Flags: needinfo?(f1jek01)
(Reporter)

Comment 13

6 years ago
Hi, I have a stupid question : how do I get and put on my device the very last build ?
(Reporter)

Comment 14

6 years ago
'scuse it's OK, I have seen the link above... I try.
(Reporter)

Comment 15

6 years ago
It's good for me.

The nightly build works correctly with the external Fr keyboard in the address bar AND in all the input fields, even the password ones. For me it's perfect.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(In reply to f1jek01 from comment #15)
> It's good for me.
> 
> The nightly build works correctly with the external Fr keyboard in the
> address bar AND in all the input fields, even the password ones. For me it's
> perfect.

Great! Thank you for all your help!
(Reporter)

Comment 17

6 years ago
Thanks to all the developpers ! 
When will this version be available trought the normal setup from android market ?
Firefox 20; a little ways off; you'll be able to use Aurora for Android (http://aurora.mozilla.org)_ in the next few weeks which will have the fix and be a little more stable.
You need to log in before you can comment on or make changes to this bug.