Support numeric in calc()

RESOLVED DUPLICATE of bug 594933

Status

()

RESOLVED DUPLICATE of bug 594933
6 years ago
6 years ago

People

(Reporter: thomas, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mentor=thomas@thomasy.tw][lang=c++][good first bug])

(Reporter)

Description

6 years ago
Support numeric only value like calc(1 + 1) , calc(2) in CSS
(Reporter)

Updated

6 years ago
Whiteboard: [mentor=thomas@thomasy.tw][lang=c++][good first bug]
First, isn't this basically a duplicate of bug 594933?

Second, I don't think this should be marked "good first bug"; I think it's actually rather hard and requires rewriting a good part of the input validation in the calc() parsing code.
You need to log in before you can comment on or make changes to this bug.