Closed Bug 793637 Opened 7 years ago Closed 7 years ago

Hang on shutdown of Firefox (when installing an update)

Categories

(Core :: Networking, defect, critical)

17 Branch
All
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 729536
Tracking Status
firefox17 - affected

People

(Reporter: whimboo, Assigned: jaas)

Details

Attachments

(2 files)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120923042010

When I was updating Aurora from 120919 to 120923 I triggered the restart of the browser via the about window. Firefox didn't shutdown but keeps running with about 35 threads and a memory usage of 700MB. This was ongoing for a couple of minutes. After recording some information I finally had to force kill the application.

I haven't had such a situation for a long time. So far I haven't tried to reproduce but will do once the updates of today are available.
Attached file aurora report
If necessary I have an aurora trace via Instruments available. If wanted I can share it via e.g. dropbox. It's about 190MB in size. For now here the Aurora report information.
In the activity monitor sameple HTTP is waiting on ... something.  The SSL code is also waiting on ... something.  Possible deadlock there?
Component: General → Networking
Product: Firefox → Core
I have Aurora 17.0.2 hung with pretty much the same call graph as :whimboo's activity monitor sample https://bug793637.bugzilla.mozilla.org/attachment.cgi?id=663992

I'll try to get symbols and attach a debugger...
Irving, do you see the same in 18.0 or even 16.0 beta? The latter could possibly be a blocker.
I've only been running Aurora, and I don't have steps to reproduce. Unfortunately when I tried to attach a debugger the hung process exited, so I don't have any more evidence except a saved Activity Monitor sample.
I have updated from yesterdays to todays build without a hang involved now. It could be related to a hibernation which I haven't done during today. I will keep an eye on it.
Tracking for now, and sending over to Ehsan to take a look at the sample when he gets the chance. I suspect that if this happens around updates, bgupdates may be implicated.
Assignee: nobody → ehsan
This has every indication of being a deadlock.  I don't see any evidence to believe that this has anything to do with bgupdates.
Assignee: ehsan → nobody
Thanks Ehsan.

Josh - can you recommend somebody to take a look at this on the networking side?
Assignee: nobody → joshmoz
Patrick, Brian, Honza - any idea what is going on here?
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 729536
no need to track, duplicate of a bug that's been around since 13.
You need to log in before you can comment on or make changes to this bug.