Perma-purple Linux opt "ValueError: invalid literal for float(): __codesizeDiff.0" on Try

RESOLVED FIXED

Status

Release Engineering
General Automation
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: bhearsum, Assigned: jhopkins)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [purple])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I keep seeing exceptions like this in the buildbot master twistd.log mail:

Exception in /builds/buildbot/try1/master/twistd.log.1:
2012-09-24 05:26:00-0700 [-] Unhandled Error
	Traceback (most recent call last):
	  File "/builds/buildbot/try1/lib/python2.6/site-packages/twisted/internet/defer.py", line 249, in addCallbacks
	    self._runCallbacks()
	  File "/builds/buildbot/try1/lib/python2.6/site-packages/twisted/internet/defer.py", line 441, in _runCallbacks
	    self.result = callback(self.result, *args, **kw)
	  File "/builds/buildbot/try1/lib/python2.6/site-packages/twisted/internet/defer.py", line 318, in callback
	    self._startRunCallbacks(result)
	  File "/builds/buildbot/try1/lib/python2.6/site-packages/twisted/internet/defer.py", line 424, in _startRunCallbacks
	    self._runCallbacks()
	--- <exception caught here> ---
	  File "/builds/buildbot/try1/lib/python2.6/site-packages/twisted/internet/defer.py", line 441, in _runCallbacks
	    self.result = callback(self.result, *args, **kw)
	  File "/builds/buildbot/try1/lib/python2.6/site-packages/buildbot-0.8.2_hg_bd4812420e63_production_0.8-py2.6.egg/buildbot/process/buildstep.py", line 1072, in <lambda>
	    d.addCallback(lambda res: self.createSummary(cmd.logs['stdio']))
	  File "/builds/buildbot/try1/lib/python2.6/site-packages/buildbotcustom/steps/test.py", line 274, in createSummary
	    bytes = formatBytes(rawBytes)
	  File "/builds/buildbot/try1/lib/python2.6/site-packages/buildbotcustom/steps/test.py", line 75, in formatBytes
	    bytes=float(str(bytes) + '.0')
	exceptions.ValueError: invalid literal for float(): __codesizeDiff.0
These are caused by the leak tests failing. In any case, our parsing code should be able to handle this better.
Depends on: 793016
Looks we hit a 20 min timeout on Linux64, but on 32bit builds the get_codesighs_diff step does:

tools/codesighs/autosummary.unix.bash -o obj-firefox -s . ../codesize-auto.log ../codesize-auto-old.log ../codesize-auto-diff.log
 in dir /builds/slave/try-lnx/build (timeout 1200 secs)
tools/codesighs/autosummary.unix.bash: obj-firefox/dist/bin/maptsvdifftool: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory
__codesize:tools/codesighs/autosummary.unix.bash: obj-firefox/dist/bin/codesighs: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory
__codesizeDiff:tools/codesighs/autosummary.unix.bash: obj-firefox/dist/bin/maptsvdifftool: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

Needs to be run in the mock step ?

Updated

5 years ago
Blocks: 438871
Severity: normal → critical
Summary: lots of "ValueError: invalid literal for float(): __codesizeDiff.0" errors lately → Perma-purple Linux opt "ValueError: invalid literal for float(): __codesizeDiff.0" on Try
Whiteboard: [orange][purple]
(Assignee)

Updated

5 years ago
Assignee: nobody → jhopkins
(Assignee)

Comment 4

5 years ago
Created attachment 665001 [details] [diff] [review]
proposed buildbotcustom patch

Patch resulted in a green Try build in staging.
Attachment #665001 - Flags: review?(catlee)

Updated

5 years ago
Attachment #665001 - Flags: review?(catlee) → review+
(Assignee)

Comment 5

5 years ago
Comment on attachment 665001 [details] [diff] [review]
proposed buildbotcustom patch

Landed in http://hg.mozilla.org/build/buildbotcustom/rev/8da36d6d1170
Attachment #665001 - Flags: checked-in+
(Assignee)

Comment 6

5 years ago
Linux try builds are now GREEN.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Keywords: intermittent-failure
Whiteboard: [orange][purple] → [purple]
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.