Closed Bug 793705 Opened 8 years ago Closed 7 years ago

Failure in testSearch/testSearchSelection.js | The tab with index '1' has been selected

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect, P2)

x86
Linux
defect

Tracking

(firefox21 wontfix, firefox22 wontfix, firefox24 wontfix)

RESOLVED WORKSFORME
Tracking Status
firefox21 --- wontfix
firefox22 --- wontfix
firefox24 --- wontfix

People

(Reporter: AlexLakatos, Unassigned)

References

()

Details

(Whiteboard: [mozmill-test-failure] s=130325 u=failure c=search p=1)

TEST: testSearch/testSearchSelection.js
ERROR: The tab with index '1' has been selected
WHEN: 24-09-2012
FIRST: 24-09-2012
FREQ: 1
So far it only failed in a localized build. Lets see if it is reoccurring.
Happened only once a half month ago. Lets reopen if we see it again.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
It happened today with Aurora de build on Linux:
http://mozmill-ci.blargon7.com/#/functional/report/2a6536e9db9f5f44ed48c58510728ca5

Think it's very rarely since we didn't encounter it on our testing for the 2 locales.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Assignee: nobody → mario.garbi
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure] s=130325 u=failure c=search p=1
 We are getting this when we try to click on a tab with "set selectedIndex" before that tab has completly loaded (using dumps of the tab width I have notice we try to click it while it has a width of 40px out of 250px).
 While I wasn't able to reproduce this locally I suspect this to happen due to a machine's low performance or firefox issue. Basically we only click once and if we misclick it the test will fail.
 I worked on a fix that waits for the tab to be fullyOpen before clicking it but I'm still trying to reproduce this in order to be sure that is the real issue.
Taking this bug since I am able to reproduce constantly (1 out of 21 runs on Linux) even when using the _fullyOpened attribute to wait for.
Assignee: mario.garbi → dpetrovici
Another failure on Linux 12.10 (x86) Aurora (FF 23 version as the above reported failure) IT:
http://mozmill-ci.blargon7.com/#/functional/report/90a0b225333a4e0c868fcb2b44e5050c
Did not happen for more than a month now
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → WORKSFORME
Tempted to reopen.

Not sure if a new bug should actually harbor these new failures:
http://mozmill-release.blargon7.com/#/functional/failure?branch=All&platform=All&from=2013-08-23&test=%2FtestSearch%2FtestSearchSelection.js&func=testSearchSelection.js%3A%3AtestSearchSelectionViaContextMenu

Failed once with a 'fa' and once with a 'ar' build.
Both on the 24 branch.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Assignee: daniela.p98911 → nobody
Has failed again today with 24.0, once with ar and fa locales, like before. I'm checking if it's reproducible now.
One was on Linux 13.04 and one on Windows Vista.

http://mozmill-release.blargon7.com/#/functional/report/26d5854914a68aa13b333f28152f3dd4
http://mozmill-release.blargon7.com/#/functional/report/26d5854914a68aa13b333f28152eeb88
Didn't happened again since then.
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → WORKSFORME
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.