Last Comment Bug 793829 - no debug symbols for in-tree freetype
: no debug symbols for in-tree freetype
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla18
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 13:29 PDT by Brad Lassey [:blassey] (use needinfo?)
Modified: 2012-10-15 10:21 PDT (History)
6 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
fixed
fixed


Attachments
patch (972 bytes, patch)
2012-09-24 13:29 PDT, Brad Lassey [:blassey] (use needinfo?)
ted: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta-
akeybl: approval‑mozilla‑release+
Details | Diff | Review

Description Brad Lassey [:blassey] (use needinfo?) 2012-09-24 13:29:58 PDT
Created attachment 664190 [details] [diff] [review]
patch
Comment 1 Ryan VanderMeulen [:RyanVM] 2012-09-25 14:37:57 PDT
https://hg.mozilla.org/mozilla-central/rev/b8c267074d62
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-09-25 14:38:02 PDT
https://hg.mozilla.org/mozilla-central/rev/b8c267074d62
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2012-10-04 17:42:17 PDT
Comment on attachment 664190 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): me not thinking we'd need symbols when I wrote this configure goop
User impact if declined: no user impact, but developers will continue to have useless stacks in crash-stats
Testing completed (on m-c, etc.): on trunk for a week, useful stacks have let us fix several bugs
Risk to taking this patch (and alternatives if risky): no risks I can identify
String or UUID changes made by this patch: none
Comment 4 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-05 15:06:18 PDT
Leaving this approval nom, we can make sure it lands post-merge on Oct 8th and gets into the first 17.0 beta
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2012-10-05 15:25:39 PDT
Lukas, I was suggesting that we get this into 16 and 17.
Comment 6 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-05 15:41:10 PDT
Comment on attachment 664190 [details] [diff] [review]
patch

Beta is representative enough that we should be able to make bugs actionable there (17), and we've already gone to build on 16 so it's unfortunately too late - fortunately this isn't too critical.
Comment 7 Lukas Blakk [:lsblakk] use ?needinfo 2012-10-05 15:48:57 PDT
Setting tracking for 16, if there was a chemspill we would consider this for a ride-along.
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-10 10:32:38 PDT
Flagging as [qa-] since I don't believe this to be something QA needs to verify.

Note You need to log in before you can comment on or make changes to this bug.