Details button on crashreporter dialogue doesn't work

VERIFIED FIXED in Firefox 20

Status

()

Toolkit
Crash Reporting
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: david.smitmanis, Assigned: vladan)

Tracking

({regression})

13 Branch
mozilla21
All
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox19 wontfix, firefox20 verified, firefox21 verified, relnote-firefox 20+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
To reproduce: get a crash, check the "Tell Mozilla" box, click on the "Details" button. Nothing happens.

Updated

5 years ago
Summary: Details button doesn't work → Details button on crashreporter dialogue doesn't work

Comment 1

5 years ago
It's applicable to all channels including Release.
Hardware: x86_64 → All
Version: 18 Branch → Trunk

Comment 2

5 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/e61a169463c6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120222 Firefox/13.0a1 ID:20120222095919
Bad:
http://hg.mozilla.org/mozilla-central/rev/49956e0cc0bb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120222 Firefox/13.0a1 ID:20120222142417
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e61a169463c6&tochange=49956e0cc0bb

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/23fef78981b5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120222 Firefox/13.0a1 ID:20120222034818
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/4720524d2eab
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120222 Firefox/13.0a1 ID:20120222045818
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=23fef78981b5&tochange=4720524d2eab


Suspected: 
4720524d2eab	Ted Mielczarek — bug 602565 - Make crashreporter client use Rich Edit 4.1 control to fix display of Indic scripts. r=ehsan
Blocks: 602565

Updated

5 years ago
Keywords: regression

Updated

5 years ago
Version: Trunk → 13 Branch

Comment 3

5 years ago
Just so that its said, wfm on linux, so it seams to be windows only.
That's not terribly surprising since each platform has its own separate UI implementation, but thanks for checking that.
(Assignee)

Comment 5

5 years ago
I'm still seeing this behavior
(Assignee)

Comment 6

5 years ago
(In reply to Vladan Djeric (:vladan) from comment #5)
> I'm still seeing this behavior

.. on Windows after every crash
(Assignee)

Comment 7

4 years ago
Created attachment 708846 [details] [diff] [review]
Use a RichEdit v4.1 control in the "Details" dialog

I tested Ted's idea to use a RichEdit v4.1 control in this dialog. I can confirm it fixes the problem on Windows. We might want to uplift this fix.
Attachment #708846 - Flags: review?(ted)
Comment on attachment 708846 [details] [diff] [review]
Use a RichEdit v4.1 control in the "Details" dialog

Review of attachment 708846 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for missing that. This is a trivial fix and I would support landing it on any branch.
Attachment #708846 - Flags: review?(ted) → review+
(Assignee)

Comment 9

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/83be9ac1f2eb
(Assignee)

Comment 10

4 years ago
Comment on attachment 708846 [details] [diff] [review]
Use a RichEdit v4.1 control in the "Details" dialog

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 602565
User impact if declined: The "Details" button in the Crash Reporter dialog will not work
Testing completed (on m-c, etc.): Built locally and confirmed the "Details" button works again. mozilla-inbound tests passed
Risk to taking this patch (and alternatives if risky): None, if this patch does not work, the "Details" button will remain broken
String or UUID changes made by this patch: None
Attachment #708846 - Flags: approval-mozilla-beta?
Attachment #708846 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/83be9ac1f2eb
Assignee: nobody → vdjeric
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Comment on attachment 708846 [details] [diff] [review]
Use a RichEdit v4.1 control in the "Details" dialog

I don't think we can 100% guarantee that the only possible regression here would be a still non-functioning button. This is a longstanding issue, and therefore does not require an urgent fix. We should be very cautious when making any changes to crash reporting. Please uplift to Aurora. Thanks!
Attachment #708846 - Flags: approval-mozilla-beta?
Attachment #708846 - Flags: approval-mozilla-beta-
Attachment #708846 - Flags: approval-mozilla-aurora?
Attachment #708846 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/7ae9da4c4e50
status-firefox19: --- → wontfix
status-firefox20: --- → fixed
status-firefox21: --- → fixed
relnote-firefox: --- → ?
relnote-firefox: ? → 20+
Verified with Firefox 20 beta 2 (build ID: 20130227063501), on a Windows 7 64-bit machine.

To test this, I've done:

1) Install Crash me! add-on
2) Provoke a crash
3) Check the "Tell Mozilla" box
4) Click on the "Details" button. A dialog shows, providing the requested information
status-firefox20: fixed → verified

Updated

4 years ago
QA Contact: manuela.muntean
Verified as Fixed on FF 21b6 on Windows 7 x64
20130430204233
Status: RESOLVED → VERIFIED
status-firefox21: fixed → verified
You need to log in before you can comment on or make changes to this bug.