Closed Bug 794010 Opened 8 years ago Closed 8 years ago

pdf.js can't open password protected documents

Categories

(Firefox :: PDF Viewer, defect)

18 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Tracking Status
firefox15 --- unaffected
firefox16 --- unaffected
firefox17 --- unaffected
firefox18 + verified

People

(Reporter: david.smitmanis, Unassigned)

References

Details

(Keywords: regression)

Pretty much what the summary says, password protected pdfs won't open, and the common "might not be displayed properly" warning shows.

From reading the github issues, this feature seems to have been addressed, so this may be a regression? Perhaps someone knows whether this has worked before at any point?

Example password protected pdf: http://atratus.se/david/losenord.pdf
Works in Release
Keywords: regression
Broken since 9/20
Regression window(m-c)
Good(Password prompt pops up as expected):
http://hg.mozilla.org/mozilla-central/rev/230b0284d50d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120920001057
Bad(Notification bar"This PDF document might not be displayed correctly" appears):
http://hg.mozilla.org/mozilla-central/rev/1e56d3016820
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120920005857
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=230b0284d50d&tochange=1e56d3016820
In local build,
Last Good: ccfc79c27dae
First Bad: 758e3d456e0b
Triggered by
	758e3d456e0b	Ms2ger — Bug 744907 - Remove BlobBuilder; r=sicking
Blocks: 744907
Seems fixed with the latest update to pdf.js.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Correction, works in the latest version of pdf.js which isn't in Nightly yet
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The fix is applied to Nightly now, and it seems like passwords work once again
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0 beta 6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121227 Firefox/20.0 20121227030822
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20121227 Firefox/20.0 20121227030822
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20121227 Firefox/20.0 20121227030822

Verified the fix on the above builds: PDFjs opens password protected PDFs successfully.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.