Closed Bug 794056 Opened 7 years ago Closed 6 years ago

window.devicePixelRatio in bogus on Galaxy Nexus with viewport set to device-width

Categories

(Core :: DOM: CSS Object Model, defect, major)

ARM
Android
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla25

People

(Reporter: hsivonen, Unassigned)

References

(Blocks 1 open bug, )

Details

Steps to reproduce:
1) Load http://mpulp.mobi/labs/ppk/widthtest.html on Galaxy Nexus (I tried with Jellybean)

Actual results:
window.devicePixelRatio is 1 even though the rendering of the background image shows that the 720 device-pixel-wide screen is 360 CSS px wide.

Expected results:
Expected window.devicePixelRatio to be 2.
Closely related to bug 779527.
Depends on: 779527
Blocks: 564815
Depends on: 803207
Ping. I can confirm this happening on a Nexus 7 tablet that should report something > 1 (either 1.3 or 1.5), but it returns 1. On normal Firefox I used the -moz-device-pixel-ratio media query while on Firefox Beta I tried using window.devicePixelRatio. Both return 1.
This should be fixed in recent nightlies. Can you please retest?
Duplicate of this bug: 896804
Fixed by bug 803207.
Target Milestone: --- → mozilla25
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #4)
> This should be fixed in recent nightlies. Can you please retest?

Yeah, it's now fixed. Thanks.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.