Block all but the latest Flash versions

RESOLVED WONTFIX

Status

()

Firefox for Android
Plugins
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: kbrosnan, Assigned: snorp)

Tracking

Trunk
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec+)

Details

(Reporter)

Description

5 years ago
I believe people are installing Flash apks that they find on the internet for their Jelly Bean devices and that some of these apks are out of date versions of Flash. Since Adobe is blocking JB devices from updating Flash on the Play Store they stay on older crashy versions of Flash.

According to my ICS device Flash 11.1.115.12 is the current version of Flash.
(Reporter)

Updated

5 years ago
tracking-fennec: --- → ?
(Reporter)

Comment 1

5 years ago
http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html#main_Archived_versions


    Flash Player 11.1.for Android 4.0 (11.1.115.17)
    Flash Player 11.1 for Android 4.0 (11.1.115.12)
    Flash Player 11.1 for Android 4.0 (11.1.115.11)
    Flash Player 11.1 for Android 4.0 (11.1.115.8)
    Flash Player 11.1 for Android 4.0 (11.1.115.7)
    Flash Player 11.1 for Android 4.0 (11.1.112.61)
    Flash Player 11.1 for Android 4.0 (11.1.112.60)

Flash Player for Android 2.x and 3.x archives

    Flash Player 11.1 for Android 2.x and 3.x (11.1.111.16)
    Flash Player 11.1 for Android 2.x and 3.x (11.1.111.10)
    Flash Player 11.1 for Android 2.x and 3.x (11.1.111.9)
    Flash Player 11.1 for Android 2.x and 3.x (11.1.111.8)
    Flash Player 11.1 for Android 2.x and 3.x (11.1.111.7)
    Flash Player 11.1 for Android 2.x and 3.x (11.1.111.5)
    Flash Player 11.1 for Android (11.1.102.59)
    Flash Player 11 for Android (11.0.1.153)
    Flash Player 10.3 for Android (10.3.186.7)
    Flash Player 10.2 for Android (10.2.157.51)
    Flash Player 10.1 for Android (10.1.106.17)
Kevin, do you know (or know how to generate) the Socorro "Debug Identifiers" for these versions of libflashplayer.so?
(Reporter)

Comment 3

5 years ago
I don't. Kairo ping.

Comment 4

5 years ago
I also don't know how to generate debug IDs. Ted should know.
Breakpad either uses the "Build ID" from the ELF header or it generates a crappy hash of the first page of the text section. If you have a Firefox for Android objdir laying around, there should be a $DIST/host/bin/file_id tool in there that you can run on any binary to dump the debug ID.
Assignee: nobody → snorp
tracking-fennec: ? → 18+
(Reporter)

Comment 6

5 years ago
For Android 2.x and 3.x Flash Player

flash-android2and3/10.1.106.17-libflashplayer.so 
E68AFCD6CD744E646D71AFE146D5C7DF0
flash-android2and3/10.1.106.17-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android2and3/10.2.157.51-libflashplayer.so 
B7CB4DD64E0D7BB182CCC3E1F4E2F01B0
flash-android2and3/10.2.157.51-libstagefright_froyo.so 
91C9A308B80CE708CC9A24A820C30ECD0
flash-android2and3/10.2.157.51-libstagefright_honeycomb.so 
62ADE620D8C95397BE4CEBD37D7508D10
flash-android2and3/10.2.157.51-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android2and3/10.3.186.7-libflashplayer.so 
00BE76CEAA7193005ECC32AF3F24F6410
flash-android2and3/10.3.186.7-libstagefright_froyo.so 
91C9A308B80CE708CC9A24A820C30ECD0
flash-android2and3/10.3.186.7-libstagefright_honeycomb.so 
62ADE620D8C95397BE4CEBD37D7508D10
flash-android2and3/10.3.186.7-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android2and3/11.0.1.153-libflashplayer.so 
79B758492FC0CC76D9CB39D8B6C446570
flash-android2and3/11.0.1.153-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android2and3/11.0.1.153-libstagefright_honeycomb.so 
F988011CBF8C244098A6C6D4840871530
flash-android2and3/11.0.1.153-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android2and3/11.1.102.59-libflashplayer.so 
79B73891135CCC7611A239D8F6C546570
flash-android2and3/11.1.102.59-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android2and3/11.1.102.59-libstagefright_honeycomb.so 
F988011CBF8C244098A6C6D4840871530
flash-android2and3/11.1.102.59-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android2and3/11.1.111.10-libflashplayer.so 
79B731A115A0CC7615A639D8B6D946570
flash-android2and3/11.1.111.10-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android2and3/11.1.111.10-libstagefright_honeycomb.so 
F988011CBF8C244098A6C6D4840871530
flash-android2and3/11.1.111.10-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android2and3/11.1.111.16-libflashplayer.so 
79B737211220CC7615A339D8B6C646570
flash-android2and3/11.1.111.16-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android2and3/11.1.111.16-libstagefright_honeycomb.so 
F988011CBF8C244098A6C6D4840871530
flash-android2and3/11.1.111.16-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android2and3/11.1.111.5-libflashplayer.so 
79B738D1139CCC7691A239D876C646570
flash-android2and3/11.1.111.5-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android2and3/11.1.111.5-libstagefright_honeycomb.so 
F988011CBF8C244098A6C6D4840871530
flash-android2and3/11.1.111.5-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android2and3/11.1.111.7-libflashplayer.so 
79B732C914A0CC7615D839D8B6C546570
flash-android2and3/11.1.111.7-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android2and3/11.1.111.7-libstagefright_honeycomb.so 
F988011CBF8C244098A6C6D4840871530
flash-android2and3/11.1.111.7-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android2and3/11.1.111.8-libflashplayer.so 
79B731211420CC7615A739D8B6C646570
flash-android2and3/11.1.111.8-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android2and3/11.1.111.8-libstagefright_honeycomb.so 
F988011CBF8C244098A6C6D4840871530
flash-android2and3/11.1.111.8-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android2and3/11.1.111.9-libflashplayer.so 
79B731211420CC7615A739D8B6C646570
flash-android2and3/11.1.111.9-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android2and3/11.1.111.9-libstagefright_honeycomb.so 
F988011CBF8C244098A6C6D4840871530
flash-android2and3/11.1.111.9-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
(Reporter)

Comment 7

5 years ago
For Android 4 Flash Player

flash-android4/11.1.112.60-libflashplayer.so 
79B72C912C3CCC7661C139D8B6C946570
flash-android4/11.1.112.60-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android4/11.1.112.60-libstagefright_honeycomb.so 
F988011CBF9C244090A6C6D48C0871530
flash-android4/11.1.112.60-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android4/11.1.112.61-libflashplayer.so 
79B72C912C3CCC7661C139D8B6C946570
flash-android4/11.1.112.61-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android4/11.1.112.61-libstagefright_honeycomb.so 
F988011CBF9C244090A6C6D48C0871530
flash-android4/11.1.112.61-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android4/11.1.115.11-libflashplayer.so 
79B723A92024CC7619C139D8B6C146570
flash-android4/11.1.115.11-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android4/11.1.115.11-libstagefright_honeycomb.so 
F988011CBF9C244090A6C6D48C0871530
flash-android4/11.1.115.11-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android4/11.1.115.12-libflashplayer.so 
79B723A92024CC7619C139D8B6C146570
flash-android4/11.1.115.12-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android4/11.1.115.12-libstagefright_honeycomb.so 
F988011CBF9C244090A6C6D48C0871530
flash-android4/11.1.115.12-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android4/11.1.115.17-libflashplayer.so 
79B72F692D64CC7699C039D8B6C646570
flash-android4/11.1.115.17-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android4/11.1.115.17-libstagefright_honeycomb.so 
F988011CBF9C244090A6C6D48C0871530
flash-android4/11.1.115.17-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android4/11.1.115.7-libflashplayer.so 
79B73C212164CC7699C039D8B6C646570
flash-android4/11.1.115.7-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android4/11.1.115.7-libstagefright_honeycomb.so 
F988011CBF9C244090A6C6D48C0871530
flash-android4/11.1.115.7-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
flash-android4/11.1.115.8-libflashplayer.so 
79B73C212164CC7699C039D8B6C646570
flash-android4/11.1.115.8-libstagefright_froyo.so 
95FE937518ACDD0524DEA4C7D40320D60
flash-android4/11.1.115.8-libstagefright_honeycomb.so 
F988011CBF9C244090A6C6D48C0871530
flash-android4/11.1.115.8-libysshared.so 
EB69F04E58DC0481DBA502F475E01D1F0
(Reporter)

Comment 8

5 years ago
Notes:
File id program is in $OBJDIR/dist/host/bin/file_id. Any .so file needs to be extracted from the APK.

Simple bash script to output the file name and hash.
for file in flash-android4/*; do echo "$file ";./file_id $file; done

If anyone needs a copy of the extracted .so files I can provide an archive.
snorp, what's the plan here?
Flags: needinfo?(snorp)
Do we for sure need to go ahead with this? I don't think I have really seen any bugs caused by this, and it's going to be a reasonably large amount of work.
Flags: needinfo?(snorp)
Flags: needinfo?(kbrosnan)
tracking-fennec: 18+ → 20+
(Reporter)

Updated

5 years ago
Depends on: 840634
tracking-fennec: 20+ → +
Kevin will coordinate with Kairo to get a report about flash versions to see if this will help with our crashes
Depends on: 839456
Just because I downloaded all these files anyway:
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.8-libstagefright_froyo.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.47-libstagefright_honeycomb.so
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.34-libstagefright_froyo.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.7-libysshared.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.12-libysshared.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.20-libysshared.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.34-libstagefright_honeycomb.so
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.7-libstagefright_froyo.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.27-libstagefright_honeycomb.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.20-libstagefright_honeycomb.so
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.17-libstagefright_froyo.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.36-libstagefright_honeycomb.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.37-libstagefright_honeycomb.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.27-libysshared.so
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.36-libstagefright_froyo.so
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.27-libstagefright_froyo.so
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.11-libstagefright_froyo.so
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.12-libstagefright_froyo.so
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.47-libstagefright_froyo.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.17-libstagefright_honeycomb.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.12-libstagefright_honeycomb.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.47-libysshared.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.48-libysshared.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.37-libysshared.so
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.48-libstagefright_froyo.so
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.54-libstagefright_froyo.so
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.37-libstagefright_froyo.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.11-libysshared.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.8-libysshared.so
MODULE Linux arm 95FE937518ACDD0524DEA4C7D40320D60 11.1.115.20-libstagefright_froyo.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.11-libstagefright_honeycomb.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.54-libysshared.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.17-libysshared.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.48-libstagefright_honeycomb.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.36-libysshared.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.54-libstagefright_honeycomb.so
MODULE Linux arm EB69F04E58DC0481DBA502F475E01D1F0 11.1.115.34-libysshared.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.8-libstagefright_honeycomb.so
MODULE Linux arm F988011CBF9C244090A6C6D48C0871530 11.1.115.7-libstagefright_honeycomb.so

(there's probably some overlap with kbrosnan's list above)
I don't think we're really seeing people using incorrect versions. Closing this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 14

4 years ago
Yeah.
(Reporter)

Updated

4 years ago
Flags: needinfo?(kbrosnan)
You need to log in before you can comment on or make changes to this bug.