RFE need key binding to cycle windows

RESOLVED INVALID

Status

()

Core
Keyboard: Navigation
--
enhancement
RESOLVED INVALID
17 years ago
16 years ago

People

(Reporter: Jon Willeke, Assigned: Matthew Paul Thomas)

Tracking

({helpwanted})

Trunk
Future
x86
Windows NT
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9) Gecko/20010505
BuildID:    2001050515

Previous versions of Navigator allowed you to cycle the active browser window by
pressing <Ctrl>-<Tab>, a convention observed by most Windows applications.

The Tasks menu shows the other windows, so it's clear that Mozilla is aware of them.

Reproducible: Always
Steps to Reproduce:
1. Open more than one browser window.
2. Press <Ctrl>-<Tab>.


Actual Results:  Current browser window remains active.

Expected Results:  Another browser window should have been activated.

Comment 1

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Component: User Interface Design → Keyboard Navigation
Ever confirmed: true
Keywords: 4xp
(Assignee)

Comment 2

17 years ago
In Seamonkey (this version of Mozilla), Control+Tab will no longer switch 
between open windows. This never made much sense anyway, because Windows 
already provided a perfectly good shortcut (Alt+Tab) for switching between 
windows.

Instead, Control+Tab will cycle between the address field, the sidebar, and the 
content area. See bug 24423 for details.

Marking as invalid, because the non-switching of windows is not a bug.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
I would like to share some of my experience here.
I used to have opened up a dozon or more browsing windows when surfing websites 
and watching news.

And yes, Windows does provide a keyboard shortcut (Alt-Tab) to switch between 
different windows.

BUT, it has two (at least) shortcomings:
1) When using Alt-Tab, a small pop-up window will show up and you have to locate 
the correct application to switch to.
2) Alt-Tab will cycle through *other* non-browser apps windows too.

These shortcomings hinder the speed in switching to other *browsing* windows and 
require the user (you can say - me) to visually check before switching in order 
to prevent landing on non-browsing window.

Hope you can understand how useful and handy the Ctrl-Tab key in NS4 make my 
surfing more smoothly and quickly.
(Reporter)

Comment 4

17 years ago
doctor__j summarized it quite well.  If I have five Mozilla windows open and, 
say, five TeraTerm windows, <Ctrl>-<Tab> cuts in half the number of keypresses 
to get to the desired window.  (Yes, I'm using TeraTerm as an example, because 
it supports the <Ctrl>-<Tab> convention.)

It's a convention that started with MDI applications, but makes perfect sense 
with an SDI Mozilla.  I know that IE has abandoned <Ctrl>-<Tab>, but that can 
hardly be a justification.

Comment 5

17 years ago
You learn something new every day.  Yesterday I learned about ctrl-tab 
(possibly again, it might have been mentioned in earlier bugs many months ago). 
Today I learn that teraterm (which i use w/ many windows) does this too.

Quick research: ctrl-tab in netscape and teraterm is only bound for non dialog 
windows. [If you use ctrl tab, you will get stuck 

I'm reopening this bug [as an enhancement] because at some point we _will_ 
support optional user keybindings. And this one should be among them.

ctrl+shift+tab navigates backwards through the cycle in tera term.
Severity: minor → enhancement
Status: RESOLVED → REOPENED
Keywords: helpwanted
Resolution: INVALID → ---
Summary: <Ctrl>-<Tab> no longer cycles active windows → RFE optional Ctrl [shift] Tab binding to cycle windows
Target Milestone: --- → Future

Comment 6

16 years ago
Are you guys aware that you can cycle through browser windows using "Ctrl-1" on
Windows and "Cmd-1" on a Mac?  (FYI:  that is the number "1", not a lowercase
"L").  This only cycles through browser windows, not mail/news windows.  

Comment 7

16 years ago
We need an option for cycling through tabs!
I really neeed this :)

Comment 8

16 years ago
It would be great a good keybinding for this, which can be used for tabbed mode
as well.

However, we can't use the key that's reserved for frame+pane navigation.

The suggestion that we use Ctrl+(shift)+tab both for switching windows and
navigating panes and frames doesn't work well - what if several of the pages are
framed pages?

I like Ctrl+1, which as Brian Clark metioned, already works quite well. 
Summary: RFE optional Ctrl [shift] Tab binding to cycle windows → RFE need key binding to cycle windows

Comment 9

16 years ago
Any problem with using Accel-Tilde cross-platform?  In addition to having
Accel-1 cycle Navigator windows and (pending my just-submitted bug 112788)
Accel-2 cycle Messenger windows and (if the idea catches on) Accel-3, Accel-4
and Accel-5 to cycle Chatzilla, Composer and Address Book windows.

Comment 10

16 years ago
tabs cycle w/ accel+pageup/pagedown.

we had floated accel-~ to show/hide the sidebar on macos.
accel[shift]f6 is available for window switching (windows. not macos, where 
fkeys shouldn't be used by apps -- hence the need to drop f9 and move to 
accel-~ or something).

on macos, command-tab can switch apps, i'd suggestion option-tab for window 
switching.  

<LafinJack> the two main program switchers let you use command-, option-, or 
control-tab to switch apps (for 9, that is)

I'm flexible about command v. option(alt) v. control, but we should be aware of 
OSX which I think uses command.

Program Switcher http://www.programswitcher.com/
liteswitch http://proteron.com/liteswitch/

fwiw picking Tab instead of ~ has a few major advantages (a) it's a logical 
pair, (b) it's much more intl safe.
Status: REOPENED → NEW
(Assignee)

Comment 11

16 years ago
Marking invalid, again, since this would make Mozilla worse rather than being an
enhancement.

Where you are on a platform where (a) the window manager does not have its own
shortcut for switching windows and (b) there is no choice of window manager for
that platform, then Mozilla can make life slightly more tolerable by having its
own shortcut. Luckily, Mozilla runs on only one such platform (Mac OS), and we
have a separate bug for that already. On all other platforms, it makes no sense
to have a superfluous shortcut which cycles through your Slashdot windows, your
mail/news windows, your online banking windows, and your HTML editor windows,
but which does *not* also cycle through your spreadsheet windows, your word
processor windows, and your Yahoo Messenger windows. You would be constantly
wasting time trying to remember whether the particular window you wanted
happened to be run by Mozilla or not, rather than just using Alt+Tab for everything.
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.