B2G STK: RIL_REQUEST_STK_SEND_ENVELOPE_WITH_STATUS not supported on Otoro

RESOLVED WONTFIX

Status

()

Core
DOM: Device Interfaces
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: hsinyi, Assigned: vicamo)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
We need RIL_REQUEST_STK_SEND_ENVELOPE_WITH_STATUS for our partner's SIM apps but otoro doesn't support it. We may be able to use REQUEST_STK_SEND_ENVELOPE_COMMAND instead, but that will cause some inconsistency with spec.
(Reporter)

Comment 1

6 years ago
CC to M. Vines:

Hi Michael,
We need this request supported. Do you have any idea? Thank you.
blocking-basecamp: --- → ?
I suggest you write the code assuming that this ril command functions as documented in ril.h
(Reporter)

Comment 3

6 years ago
(In reply to Michael Vines [:m1] from comment #2)
> I suggest you write the code assuming that this ril command functions as
> documented in ril.h
Yes, we already did that with the assumption, according to ril.h in sgs2/nexus repos. But this command in *not* defined in ril.h in the otoro repo. It returns "RIL_E_REQUEST_NOT_SUPPORTED" on otoro.
(In reply to Michael Vines [:m1] from comment #2)
> I suggest you write the code assuming that this ril command functions as
> documented in ril.h

Hi Michael,
Also can you take a look in Bug 794751?
It's a ril request defined in ril.h, but when I use it the error code is "not supported"

Thanks
(Reporter)

Updated

6 years ago
Blocks: 791161
STK is a v1 P1.
blocking-basecamp: ? → +
Yoshi, are you going to take this one?
Assignee: nobody → allstars.chh
Please disregard comment 2.  This command is not supported, why do you think it's required?
(Assignee)

Comment 8

6 years ago
(In reply to Michael Vines [:m1] from comment #7)
> Please disregard comment 2.  This command is not supported, why do you think
> it's required?

Android uses this command to perform SMS-PP download. Is there any other replacement or work-around available?
The modem handles SMS-PP download.
Hi Michael, 
How about Call Control in STK(SIM Toolkit), since the Call Control Envelope command will need the status code.

Thank you.
Duplicate of this bug: 794404
From Bug 794404 comment 10, Vicamo is already working on this.
Assignee: allstars.chh → vyang
(Assignee)

Comment 13

6 years ago
(In reply to Yoshi Huang[:yoshi][:allstars.chh] from comment #12)
> From Bug 794404 comment 10, Vicamo is already working on this.

Yoshi told me that he had tried to modify HsinYi's patch in bug 791939 to send stk command through RIL_REQUEST_STK_SEND_ENVELOPE_COMMAND rather than REQUEST_STK_SEND_ENVELOPE_WITH_STATUS. The response parcel contained nothing but a generic error code as in other RIL requests. There was neither SW1/SW2, nor reponse hex string found.

I've tried to dig out STK envelope command handling source code in CodeArura but in vain. If the underlying rild just does not prepare any response for us in RIL_REQUEST_STK_SEND_ENVELOPE_COMMAND, this issue becomes invalid because we can't solve it in any way. We're going to ask our partner whether there exists a use case that rild returns something more.
(Assignee)

Comment 14

6 years ago
After lab tests, there is no known case that the corresponding response comes with additional octets. As a result, the call control feature is completely broken in Otoro and we should make the call directly as what's done in bug 791939. I'm going to close this issue as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.