The default bug view has changed. See this FAQ.

Nightly 27/9: no more backspace nor arrows on the deck Asus Transformer

RESOLVED FIXED in Firefox 17

Status

()

Firefox for Android
Keyboards and IME
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: roumensois@gmail.com, Assigned: m_kato)

Tracking

({regression})

18 Branch
Firefox 18
ARM
Android
regression
Points:
---

Firefox Tracking Flags

(firefox16- wontfix, firefox17+ fixed, firefox18+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Installed nightly build 27/09 to solve problem with bug 669361. Bug solved.


Actual results:

Backspace and arrows keys on the deck are not recognized


Expected results:

Shoud be recognized
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → NEW
Component: General → Keyboards and IME
Ever confirmed: true
OS: Windows 7 → Android
Hardware: x86 → ARM

Updated

5 years ago
Blocks: 669361
tracking-firefox16: --- → ?
tracking-firefox17: --- → ?
tracking-firefox18: --- → ?
Keywords: regression
Version: unspecified → Firefox 18

Comment 1

5 years ago
We don't plan to take bug 669361 for FF16, so no need to track there.
Assignee: nobody → cpeterson
tracking-firefox16: ? → -
tracking-firefox18: ? → +
QA Contact: aaron.train
Tracking for 17, if bug 669361 is uplifted to 17, we'll want this too.
tracking-firefox17: ? → +
Created attachment 666460 [details] [diff] [review]
fix

onKeyDown/onKeyUp/onKeyMultiple shouldn't return false
Attachment #666460 - Flags: review?(cpeterson)
Comment on attachment 666460 [details] [diff] [review]
fix

Review of attachment 666460 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #666460 - Flags: review?(cpeterson) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/ac5c29ec176b
Assignee: cpeterson → m_kato
Target Milestone: --- → Firefox 18
https://hg.mozilla.org/mozilla-central/rev/ac5c29ec176b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox18: --- → fixed
Resolution: --- → FIXED
Comment on attachment 666460 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 669361
User impact if declined: Asus Transformer's hardware keyboards will always have en-US key layouts, regardless of user locale.
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): If bug 669361 is uplifted to fix Asus Transformer's hardware keyboard layouts, then this patch must also bug uplifted (to fix a regression from bug 669361).
String or UUID changes made by this patch: N/A
Attachment #666460 - Flags: approval-mozilla-aurora?
Comment on attachment 666460 [details] [diff] [review]
fix

approving for aurora since this is needed by the fix in bug 669361, please land before monday oct 8th merge.
Attachment #666460 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/4411e891e61f
status-firefox16: --- → wontfix
status-firefox17: --- → fixed
You need to log in before you can comment on or make changes to this bug.