Speculatively open connections for sites when hovering unrestored background tabs

RESOLVED DUPLICATE of bug 874533

Status

()

defect
RESOLVED DUPLICATE of bug 874533
7 years ago
2 years ago

People

(Reporter: johan.charlez, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Snappy])

(Reporter)

Description

7 years ago
Tim already had the idea to speculatively open connections for sites when hovering a pending tab

I'm merely filing a bug for this.

Related: bug 789889 and bug 790882
(Reporter)

Updated

7 years ago
Summary: [Pending Tabs] Speculatively open connections for sites when hovering a pending tab → [Pending Tabs] Speculatively open connections for sites when hovering pending tabs
Don't we restore from cache most of the time?
Summary: [Pending Tabs] Speculatively open connections for sites when hovering pending tabs → Speculatively open connections for sites when hovering pending tabs
(Reporter)

Comment 2

7 years ago
(In reply to Dão Gottwald [:dao] from comment #1)
> Don't we restore from cache most of the time?

Would it not be more desirable load an up-to-date page, rather than to restore a page that could very well be out of date?
 
See bug 792585 (related) and bug 706970 (related?).
Flags: qe-verify?
Priority: -- → P2
Whiteboard: [Snappy] → [photon-performance] [Snappy]

Updated

2 years ago
Summary: Speculatively open connections for sites when hovering pending tabs → Speculatively open connections for sites when hovering unrestored background tabs
Priority: P2 → P3
Whiteboard: [photon-performance] [Snappy] → [reserve-photon-performance] [Snappy]
Flags: qe-verify? → qe-verify-
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 874533
Flags: qe-verify-
Priority: P3 → --
Whiteboard: [reserve-photon-performance] [Snappy] → [Snappy]
You need to log in before you can comment on or make changes to this bug.