Closed Bug 795388 Opened 8 years ago Closed 8 years ago

Develop Plan & Reqs For API Load Testing

Categories

(Participation Infrastructure :: Phonebook, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bensternthal, Unassigned)

References

Details

(Whiteboard: [qa-wanted][soak testing])

Attachments

(2 files, 2 obsolete files)

We need to know how much we can handle.

Will try to work with QA on this one.
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [qa-wanted][soak testing]
Matt, can you report on the results of what you have found?

We can review with Giorgos and close this one out.

Again thanks for your help with this.
Attached file funktest report - 2012-7-11 (obsolete) —
Perfect -- good call on filing a bug to track this. Here is a copy of the report -- the report covers a test run where a 1, 50, 100, and 200 users concurrently ping the api twice.


This is the url that the test is pinging:
https://mozillians.allizom.org/api/v1/users/?app_name=mozapp&app_key=test&format=json&limit=500
Marking as resolved.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Attached file The actual results. (obsolete) —
The funk tests zip did not contain the results of the testing.
I'll remedy this -- give me a few moments to find/generate a new report.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Sorry folks, here's the true report.
Attachment #679441 - Attachment is obsolete: true
Attachment #679819 - Attachment is obsolete: true
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Final results of the performance benchmarking are complete - attachment 681656 [details]
Status: RESOLVED → VERIFIED
Duplicate of this bug: 810119
You need to log in before you can comment on or make changes to this bug.