Closed Bug 795552 Opened 7 years ago Closed 7 months ago

Firefox mobile should Text reflow on zooming as Opera mobile

Categories

(Firefox for Android :: Toolbar, enhancement)

ARM
Android
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 710298
Tracking Status
firefox66 --- affected

People

(Reporter: vulcain, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120907231657

Steps to reproduce:

When you go to https://www.mozilla.org/fr/about/ and try to zoom, the text don't reflow after zoom.

An exemple in another browser: http://www.youtube.com/watch?v=iqpcz5wAMLQ

Tested on Nexus S with Android 4.1.1 with Firefox 15.0.1 and with Firefox beta 16.0
Work with Opera 12.0.4

French forum (http://www.geckozone.org/forum/viewtopic.php?p=706799#p706799) tested on HTC Sensation XE with Sense 3.6, Android 4.0.3 :
Opera mobile 12.0.4 : text reflow on zooming : OK
Firefox 15.0.1 : text reflow on zooming : NO
Firefox beta 16.0 : text reflow on zooming : NO
Firefox nightly 18.0a1 : text reflow on zooming : NO


Actual results:

Only zoom but i must move to see all the text in a paragraph


Expected results:

Reflow the paragraph where i zoom
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: General → Graphics, Panning and Zooming
Ever confirmed: true
OS: Linux → Android
Hardware: x86_64 → ARM
Version: Firefox 15 → unspecified
@ Aaron: If i undestand good, Mozilla work on this ??
(In reply to vulcain from comment #2)
> @ Aaron: If i undestand good, Mozilla work on this ??

Yes.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: reflow-zoom
Is there a way to undo that change? Maybe install addon or something?

It worked perfectly before, now browser is unusable for me. Why fix something that is not broken?
Please return text reflow to Firefox!

I was on Firefox 25 and have had to revert back to Firefox 23, and stuck on it. Whatever the reason, it's NEVER suitable to have to scroll left to right on a phone to read text.

And in real world terms that's the Firefox 24+ reality, the fangled automatic font size setting doesn't work. Give the user the control!

It may not have been perfect from a technical stand point but from a user stand point, if it ain't broke don't fix it.

Bring it back as an optional setting, leave it disabled if you like.

Incidentally Samsung have broken text reflow on Galaxy phones, so don't even get it on the Android browser or Chrome.

Text reflow is such an incredible must have!
There are plans but it is not a priority right now at the moment. We actually are looking for resources and persons to pick up the work that is remaining to bring it back. Ultimately, we removed it as we weren't satisfied with the quality of it. We hear you, a number of us want it back as well.
Thanks for the reply.

But surely it's better than expecting users to have to scroll left and right constantly? That's the reality now. It may not have been satisfactory but it was better than what we're left with.


Surely remove it when the fixed code is ready, not remove it then leave a gaping hole in its place.


It makes Firefox (any browser) so annoying to use. Most websites simply weren't designed for phones.
(In reply to Aaron Train [:aaronmt] from comment #7)
> There are plans but it is not a priority right now at the moment. We
> actually are looking for resources and persons to pick up the work that is
> remaining to bring it back. Ultimately, we removed it as we weren't
> satisfied with the quality of it. We hear you, a number of us want it back
> as well.

What is the point of removing OPTIONAL feature that can be disabled at any time in settings? And if I remember correctly, it was also turned off by default so there is no reason that you killed it off.
Agreed. It was off by default so most wouldn't have used it anyway. I thought it odd it was off by default. It's incredibly useful.
But low priority in real terms means we're not getting it back. There'll be stacks of other things considered a higher priority.


I just don't understand how it's considered better for users on phones especially to have to move left to right now?
A browser without text reflow capability is useless to me on a smartphone :(

As a result, I ditched Firefox and now I'm using Boat Browser which HAS the text reflow!

I won't use Firefox anymore if they don't bring back the text reflox :-\
It's so strange Opera is now the only big browser manufacturer for Android that still supports it.

Chrome doesn't either. It's always been there on HTC phones, not Galaxys though.

The trouble for me is Firefox Sync is very useful and I've no intention of ditching Firefox Desktop, so expect I'll be using Firefox Mobile 23 for a while yet. Which is irritating.

The importance of text reflow on a mobile cannot be underestimated. Hopefully when I get a tablet I can use the latest version as should be less important.
Yeah these are dark times for text overflow. With Kitkat, WebView is based on Chrome which means all of WebView-based browsers (majority of browsers on android, including HTC browser) will loose that functionality.

Luckily, dolphin just made their own engine which surprisingly supports text reflow. So now we have a choice between two browsers instead of just opera.
(In reply to alexmcc78 from comment #13)
> It's so strange Opera is now the only big browser manufacturer for Android
> that still supports it.
> 
> Chrome doesn't either. It's always been there on HTC phones, not Galaxys
> though.
> 
> The trouble for me is Firefox Sync is very useful and I've no intention of
> ditching Firefox Desktop, so expect I'll be using Firefox Mobile 23 for a
> while yet. Which is irritating.
> 
> The importance of text reflow on a mobile cannot be underestimated.
> Hopefully when I get a tablet I can use the latest version as should be less
> important.

The Pro version of Boat browser allows you to import your Firefox bookmarks.

Alternativly there's Mercury browser which also has the text reflow, but I don't think you can import you Firefox bookmarks.
Whiteboard: DUPEME
(In reply to Aaron Train [:aaronmt] from comment #7)
> Ultimately, we removed it as we weren't
> satisfied with the quality of it. We hear you, a number of us want it back
> as well.

But this doesn't make any sense! It's better to have not perfect feature that works instead of not having one... Which in my case results in opening links more and more in opera because at least I can read the contents in the sane manner there.

Given that we are in this weird "mobile first" it's even more weird that this feature is still missing (and no, TextReflow addon doesn't work well and requires quite a lot of work)…
(In reply to Aaron Train [:aaronmt] from comment #7)
> There are plans but it is not a priority right now at the moment. We
> actually are looking for resources and persons to pick up the work that is
> remaining to bring it back. Ultimately, we removed it as we weren't
> satisfied with the quality of it. We hear you, a number of us want it back
> as well.

It would really be very helpful if this problem were to continue to be addressed. There are some who consider this feature indispensable. It would also be a unique selling point with which users could be generated. Competitors can't.

A friend of mine https://twitter.com/duckpoultry suggested I might like this feature. and pointed out that opera supports it: https://blogs.opera.com/mobile/2015/12/force-enable-zoom-opera-34-for-android/ He's right, I do like it and I'd love it if firefox supported it.

I tried it just now in Opera and reflowing text with pinch-to-zoom is quite nice. I tried my own blog and news.com.au. If I added a plugin for inverse-high-contrast like I have in FIrefox it'd be amazing, and more convenient/quicker than Firefox's reader mode.

I've re-opened this bug because the firefox behaviour and Opera behavour are different, and the opera behaviour is better (in my oppinion as a user). I'm expecting people to disagree with me from the perspective as web developers or something about standards or what-not, and that's possibly legitamate, but please do try Opera and see if you like that behaviour better as a user. Ask someone with poor eyesight like a senior citizen what they like.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
See Also: → reflow-zoom
Status: REOPENED → RESOLVED
Closed: 7 years ago7 months ago
Resolution: --- → DUPLICATE
See Also: reflow-zoom
Duplicate of bug: reflow-zoom

Seven years! –and still Mozilla don't give a damn.

Add me to the list of long-time Firefox users on desktop who've abandoned it on mobile because, as has been pointed out time and time again, a mobile browser without text-reflow is literally unusable on a phone screen. In fact, it's led me to abandoning Firefox on desktop now as well, as there's no point using a different browser on desktop and mobile, as I lose all the synchronisation options. I now use Yandex Browser across mobile and desktop.

You can add Yandex Browser to the list of alternatives provided by previous posters. It not only has text-reflow but also supports Chrome extensions. It's not perfect. I personally have a few niggles with it. But it's by far the best mobile browser I've found. The only one that combines Firefox's support for extensions with Opera's text-reflow.

You need to log in before you can comment on or make changes to this bug.