Closed Bug 795588 Opened 9 years ago Closed 8 years ago

Privacy policy link is 404

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(firefox23 verified)

RESOLVED FIXED
Firefox 23
Tracking Status
firefox23 --- verified

People

(Reporter: unghost, Assigned: mkohler)

Details

Attachments

(1 file, 1 obsolete file)

STR:
1) Install Firefox 16.0 beta (russian build in my case)
2) Open about: page
3) Tap on "Privacy policy"

Expected result: Browser opens https://www.mozilla.org/en-US/legal/privacy/firefox.html 

Actual result: Browser opens http://www.mozilla.org/ru/m/privacy.html which is 404.
Assignee: nobody → michaelkohler
Version: unspecified → Trunk
Assignee: michaelkohler → nobody
Component: General → ru / Russian
Product: Firefox for Android → Mozilla Localizations
Version: Trunk → unspecified
Aaron, are you sure this is only ru/Russian?

Firefox for Android uses http://www.mozilla.com/%LOCALE%/m/privacy.html .

A quick test showed that replacing %LOCALE% with the following strings leads to a 404 too.

en/en-US/EN-US/en-us
de/DE-de/DE-DE/de-de
Component: ru / Russian → General
Product: Mozilla Localizations → Firefox for Android
Assignee: nobody → michaelkohler
Attached patch Patch v1 (obsolete) — Splinter Review
I didn't find any localized page of the privacy page, so I hardcoded it to en-US.
Attachment #684865 - Flags: review?(bnicholson)
I don't what the correct URL is that we should use here. Lawrence/Ricky, do you know? (Hopefully you're the right people to ask - I got your names from your comments in the similar bug 702319)
I would know for SUMO but not for mozilla.org. CCing Rik and pmac
AFAIK, https://www.mozilla.org/en-US/legal/privacy/firefox.html is the correct link. I'm not aware of a mobile version of this page. Perhaps a useful request to make.

cc Jishnu for comment.
Comment on attachment 684865 [details] [diff] [review]
Patch v1

I'll assume this is the correct URL to use since I haven't seen any comments saying otherwise.
Attachment #684865 - Flags: review?(bnicholson) → review+
I looks to me like http://www.mozilla.org/en-US/legal/privacy/ might be the best URL. I'm adding Ben Sternthal as I think he might know more.
The link from #c7 is the one that desktop Aurora uses, and claims to be where translations will be posted when they're available.
Adding feedback request to Jishnu to get definitive answer. I can speculate here but I'd rather get the correct pages confirmed with legal.
Flags: needinfo?(jmenon)
Comment on attachment 684865 [details] [diff] [review]
Patch v1

Removing r+ for now until Jishnu can confirm the URL.
Attachment #684865 - Flags: review+
Hi there - https://www.mozilla.org/en-US/legal/privacy/firefox.html is the current Fx PP - there's no mobile version - working on this now
Flags: needinfo?(jmenon)
For clarity:

We're likely deprecating http://www.mozilla.org/en-US/legal/privacy/ in favor of http://www.mozilla.org/en-US/privacy/, but, within our products, we should link directly to the product's privacy policy (in this case http://www.mozilla.org/en-US/privacy/).
Comment on attachment 684865 [details] [diff] [review]
Patch v1

Michael, looks like the URL to use is http://www.mozilla.org/en-US/privacy/ according to comment 12. Thanks!
Attachment #684865 - Flags: review-
Attached patch Patch v1.1Splinter Review
Attachment #684865 - Attachment is obsolete: true
Attachment #739953 - Flags: review?(bnicholson)
Attachment #739953 - Flags: review?(bnicholson) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/dbb625a4a0e3
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
According to comment 12 the link is: http://www.mozilla.org/en-US/privacy/ on Firefox for Android 23.0a1(2013-05-12).
Duplicate of this bug: 874888
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.